Project

Profile

Help

Story #7751

closed

As an user I want to sync collections and their dependencies

Added by fao89 over 2 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
GalaxyNG
Sprint:
Quarter:
Q1-2021

Description

pulp-ansible does not sync collection dependencies.

pulp.pulp_installer collection depends on ansible.posix when trying to install pulp.pulp_installer it fails due to 404 on ansible.posix

(pulp) [vagrant@pulp3-source-fedora31 pulp_ansible]$ ansible-galaxy collection install pulp.pulp_installer -c -s http://pulp3-source-fedora31.fedora.example.com/pulp_ansible/galaxy/c8dfb750-2e25-483e-bf60-46a77e896c1d -p /tmp/tmpsenw0bck
Starting galaxy collection install process
[WARNING]: The specified collections path '/tmp/tmpsenw0bck' is not part of the configured
Ansible collections paths '/home/vagrant/.ansible/collections:/usr/share/ansible/collections'.
The installed collection won't be picked up in an Ansible run.
Process install dependency map
ERROR! Failed to find collection ansible.posix:*
Oct 26 20:27:22 pulp3-source-fedora31.fedora.example.com gunicorn[32895]: 127.0.0.1 - admin [26/Oct/2020:20:27:22 +0000] "GET /pulp_ansible/galaxy/c8dfb750-2e25-483e-bf60-46a77e896c1d HTTP/1.0" 404 77 "-" "ansible-galaxy/2.10.2 (Linux; python:3.7.9)"
Oct 26 20:27:22 pulp3-source-fedora31.fedora.example.com gunicorn[32895]: 127.0.0.1 - admin [26/Oct/2020:20:27:22 +0000] "GET /pulp_ansible/galaxy/c8dfb750-2e25-483e-bf60-46a77e896c1d/api HTTP/1.0" 301 0 "-" "ansible-galaxy/2.10.2 (Linux; python:3.7.9)"
Oct 26 20:27:22 pulp3-source-fedora31.fedora.example.com gunicorn[32895]: 127.0.0.1 - admin [26/Oct/2020:20:27:22 +0000] "GET /pulp_ansible/galaxy/c8dfb750-2e25-483e-bf60-46a77e896c1d/api/ HTTP/1.0" 200 69 "-" "ansible-galaxy/2.10.2 (Linux; python:3.7.9)"
Oct 26 20:27:22 pulp3-source-fedora31.fedora.example.com gunicorn[32895]: 127.0.0.1 - admin [26/Oct/2020:20:27:22 +0000] "GET /pulp_ansible/galaxy/c8dfb750-2e25-483e-bf60-46a77e896c1d/api/v2/collections/pulp/pulp_installer/versions/ HTTP/1.0" 200 9063 "-" "ansible-galaxy/2.10.2 (Linux; python:3.7.9)"
Oct 26 20:27:22 pulp3-source-fedora31.fedora.example.com gunicorn[32895]: 127.0.0.1 - admin [26/Oct/2020:20:27:22 +0000] "GET /pulp_ansible/galaxy/c8dfb750-2e25-483e-bf60-46a77e896c1d/api/v2/collections/pulp/pulp_installer/versions/3.8.0/ HTTP/1.0" 200 1065 "-" "ansible-galaxy/2.10.2 (Linux; python:3.7.9)"
Oct 26 20:27:22 pulp3-source-fedora31.fedora.example.com gunicorn[32895]: pulp: django.request:WARNING: Not Found: /pulp_ansible/galaxy/c8dfb750-2e25-483e-bf60-46a77e896c1d/api/v2/collections/ansible/posix/versions/
Oct 26 20:27:22 pulp3-source-fedora31.fedora.example.com gunicorn[32895]: 127.0.0.1 - admin [26/Oct/2020:20:27:22 +0000] "GET /pulp_ansible/galaxy/c8dfb750-2e25-483e-bf60-46a77e896c1d/api/v2/collections/ansible/posix/versions/ HTTP/1.0" 404 23 "-" "ansible-galaxy/2.10.2 (Linux; python:3.7.9)"

Related issues

Related to Ansible Plugin - Refactor #7777: As a developer I want collections sync machinery easier to maintainCLOSED - CURRENTRELEASEbmbouter

Actions

Also available in: Atom PDF