Project

Profile

Help

Issue #6828

closed

Task #6369: Allow bindings generation for views/viewsets without models/querysets

browsable API missing endpoints on /pulp/api/v3/

Added by fao89 over 2 years ago. Updated about 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
(Total: 0:00 h)
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation
Sprint:
Sprint 81
Quarter:
Q4-2020

Description

not all endpoints are displayed on /pulp/api/v3/ DRF issue: https://github.com/encode/django-rest-framework/issues/7354

After digging more into this, the cause is URLField from DRF, it uses django validator that introduces <! on the regex that validates the domain URLField: https://github.com/encode/django-rest-framework/blob/603aac7db10671dea1975ea3023b5488815aa1ca/rest_framework/fields.py#L885-L893 django validator: https://github.com/django/django/blob/d6aff369ad33457ae2355b5b210faf1c4890ff35/django/core/validators.py#L63-L92

We need to document to avoid URLField, and prefer CharField


Files

example.html (1.8 MB) example.html Example of html from schema view fao89, 05/26/2020 10:31 PM

Subtasks 1 (0 open1 closed)

Ansible Plugin - Issue #6860: Replace URLField with CharFieldCLOSED - DUPLICATEActions
Actions #1

Updated by fao89 over 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to fao89
Actions #2

Updated by pulpbot over 2 years ago

  • Status changed from ASSIGNED to POST
Actions #3

Updated by fao89 over 2 years ago

Actions #4

Updated by fao89 over 2 years ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 74
Actions #5

Updated by fao89 over 2 years ago

  • Description updated (diff)
  • Status changed from POST to NEW
  • Assignee deleted (fao89)
  • Tags Documentation added

After digging more into this, the cause is URLField from DRF, it uses django validator that introduces <! on the regex that validates the domain URLField: https://github.com/encode/django-rest-framework/blob/603aac7db10671dea1975ea3023b5488815aa1ca/rest_framework/fields.py#L885-L893 django validator: https://github.com/django/django/blob/d6aff369ad33457ae2355b5b210faf1c4890ff35/django/core/validators.py#L63-L92

We need to document to avoid URLField, and prefer CharField

Actions #6

Updated by fao89 over 2 years ago

  • Description updated (diff)
Actions #7

Updated by rchan over 2 years ago

  • Sprint changed from Sprint 74 to Sprint 75
Actions #8

Updated by rchan over 2 years ago

  • Sprint changed from Sprint 75 to Sprint 76
Actions #9

Updated by mdellweg about 2 years ago

This is claimed to be solved by:

https://github.com/encode/django-rest-framework/pull/7389

I think it needs to be verified, however.

Actions #10

Updated by rchan about 2 years ago

  • Sprint changed from Sprint 76 to Sprint 77
Actions #11

Updated by rchan about 2 years ago

  • Sprint changed from Sprint 77 to Sprint 78
Actions #12

Updated by rchan about 2 years ago

  • Sprint changed from Sprint 78 to Sprint 79
Actions #13

Updated by rchan about 2 years ago

  • Sprint changed from Sprint 79 to Sprint 80
Actions #14

Updated by rchan about 2 years ago

  • Sprint changed from Sprint 80 to Sprint 81
Actions #15

Updated by rchan about 2 years ago

  • Quarter set to Q4-2020
Actions #16

Updated by fao89 about 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to fao89
Actions #17

Updated by pulpbot about 2 years ago

  • Status changed from ASSIGNED to POST

Added by Fabricio Aguiar about 2 years ago

Revision 4bf98ae0

Document the URLField OpenAPI issue

https://pulp.plan.io/issues/6828 closes #6828

Actions #18

Updated by Anonymous about 2 years ago

  • Status changed from POST to MODIFIED
Actions #19

Updated by bmbouter about 2 years ago

  • Sprint/Milestone set to 3.7.0
Actions #20

Updated by pulpbot about 2 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF