Project

Profile

Help

Issue #6347

closed

File content list does not return all unique content units

Added by sajha almost 4 years ago. Updated almost 4 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Sprint 70
Quarter:

Description

https://pulp-file.readthedocs.io/en/latest/restapi.html#operation/content_file_files_list does not return all unique content units when used with a page size of ~2000 and there are multiple pages of results. To reproduce:

  1. Create and sync a large file repo (http://quartet.usersys.redhat.com/pub/fake-repos/large_file/)
  2. Retrieve content units for the repo using page_size 2000
  3. Out of 70,000 content units, roughly 69k unique records are returned.

Several units are repeated across pages leading to this discrepancy since we only query till offset 68000 with the 2000 page_size and 70k results don't consist of 70k unique units.


Files

test.sh (857 Bytes) test.sh lmjachky, 04/03/2020 11:36 PM

Also available in: Atom PDF