Project

Profile

Help

Issue #5485

Story #3821: As a user, I can migrate from Pulp 2 to Pulp 3

Migration plugin should filter only those repo types that belong to the plugin that is being migrated

Added by ipanova@redhat.com almost 2 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 61
Quarter:

Description

We should extract repo_type from repo.notes and pre-migrate only those types of the repo, alongside with its importers, distributors and repo_content_units.

Before pre-migrating repo/importers/distributors/repo_content_units we should ensure that there is no pre-migrated repository data, therefore we should delete any existing repo/importers/distributors/repo_content_unit entries.


Related issues

Has duplicate Migration Plugin - Issue #5482: Migration plugin should migrate only importers of the plugins in questionCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Has duplicate Migration Plugin - Issue #5552: All importers are migrated even for the plugins not specified for migraitonCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 27b2b632 View on GitHub
Added by ipanova@redhat.com almost 2 years ago

Migrate only those repo types that belong to the plugin that is being migrated

closes #5485 https://pulp.plan.io/issues/5485

Revision 27b2b632 View on GitHub
Added by ipanova@redhat.com almost 2 years ago

Migrate only those repo types that belong to the plugin that is being migrated

closes #5485 https://pulp.plan.io/issues/5485

Revision 27b2b632 View on GitHub
Added by ipanova@redhat.com almost 2 years ago

Migrate only those repo types that belong to the plugin that is being migrated

closes #5485 https://pulp.plan.io/issues/5485

History

#1 Updated by ipanova@redhat.com almost 2 years ago

  • Description updated (diff)

#2 Updated by ipanova@redhat.com almost 2 years ago

  • Subject changed from Migration plugin should filter only tjose repo types that belong to the plugin that is being migrated to Migration plugin should filter only those repo types that belong to the plugin that is being migrated

#3 Updated by ipanova@redhat.com almost 2 years ago

  • Is duplicate of Issue #5482: Migration plugin should migrate only importers of the plugins in question added

#4 Updated by ipanova@redhat.com almost 2 years ago

  • Is duplicate of deleted (Issue #5482: Migration plugin should migrate only importers of the plugins in question)

#5 Updated by ipanova@redhat.com almost 2 years ago

  • Has duplicate Issue #5482: Migration plugin should migrate only importers of the plugins in question added

#6 Updated by fao89 almost 2 years ago

  • Triaged changed from No to Yes

#7 Updated by ipanova@redhat.com almost 2 years ago

  • Parent task set to #3821

#8 Updated by ttereshc almost 2 years ago

  • Has duplicate Issue #5552: All importers are migrated even for the plugins not specified for migraiton added

#9 Updated by ipanova@redhat.com almost 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com
  • Sprint set to Sprint 60
  • Tags Pulp 2 to 3 Migrate added

#11 Updated by rchan almost 2 years ago

  • Sprint changed from Sprint 60 to Sprint 61

#12 Updated by ipanova@redhat.com almost 2 years ago

  • Status changed from POST to MODIFIED

#13 Updated by ipanova@redhat.com almost 2 years ago

Applied in changeset commit:pulp-2to3-migrate|27b2b6320f14044c76c5143ccabfdea0bbfaa4c6.

#14 Updated by ttereshc over 1 year ago

  • Project changed from Pulp to Migration Plugin

#15 Updated by ttereshc over 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE
  • Sprint/Milestone set to 0.1.0

#16 Updated by bmbouter over 1 year ago

  • Tags deleted (Pulp 2 to 3 Migrate)

We're removing the 'Pulp 2 to 3 Migrate' tag to allow membership of the Migration Plugin project in Redmine to be the controlling area https://pulp.plan.io/projects/migration

Please register to edit this issue

Also available in: Atom PDF