Project

Profile

Help

Issue #5552

closed

All importers are migrated even for the plugins not specified for migraiton

Added by ttereshc over 2 years ago. Updated about 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Katello-P1
Sprint:
Quarter:

Description

I'm on commit 0c7bbf000e55af5ff4c0d9266427476675e409ab of pulp-2to3-migration

I'm creating a migration plan of: {"plan":{"plugins":[{"type":"iso"}]}}

Looking at postgres logs, i see:

STATEMENT:  INSERT INTO "pulp_2to3_migration_pulp2importer" ("_id", "_created", "_last_updated", "pulp2_object_id", "pulp2_type_id", "pulp2_config", "pulp2_last_updated", "is_migrated", "pulp2_repository_id", "pulp3_remote_id") VALUES ('d46d7d05-aa36-441d-aa97-0057ee7d085e'::uuid, '2019-10-07T21:16:45.541855+00:00'::timestamptz, '2019-10-07T21:16:45.541889+00:00'::timestamptz, '5d8037efb3798907c1527b6a', 'yum_importer', NULL, '2019-09-17T01:43:14.765000+00:00'::timestamptz, false, '0d82ec8f-8cef-4902-b946-ea74cbb4ff09'::uuid, NULL)

Nothing yum related was requested.


Related issues

Is duplicate of Migration Plugin - Issue #5485: Migration plugin should filter only those repo types that belong to the plugin that is being migratedCLOSED - CURRENTRELEASEipanova@redhat.comActions
Actions #1

Updated by ttereshc over 2 years ago

  • Copied from Issue #5551: Importer config can't be null added
Actions #2

Updated by ttereshc over 2 years ago

  • Copied from deleted (Issue #5551: Importer config can't be null)
Actions #3

Updated by ttereshc over 2 years ago

  • Tags Katello-P1 added
Actions #4

Updated by ttereshc over 2 years ago

  • Is duplicate of Issue #5485: Migration plugin should filter only those repo types that belong to the plugin that is being migrated added
Actions #5

Updated by ttereshc over 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #6

Updated by ttereshc over 2 years ago

  • Project changed from Pulp to Migration Plugin
Actions #7

Updated by bmbouter about 2 years ago

  • Tags deleted (Pulp 2 to 3 Migrate)

We're removing the 'Pulp 2 to 3 Migrate' tag to allow membership of the Migration Plugin project in Redmine to be the controlling area https://pulp.plan.io/projects/migration

Also available in: Atom PDF