Project

Profile

Help

Task #4714

Remove the 'validate' field from Master Remote object

Added by amacdona@redhat.com 9 months ago. Updated about 1 month ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Platform Release:
Blocks Release:
Backwards Incompatible:
No
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:
Sprint 55

Description

The 'validate' field should be removed.

Our Master Remote includes fields that it shouldn't. In our original planning, the fields that were included seem to be "all fields that many plugins will probably need". This sends a mixed message to plugin authors, who may not be familiar with how or if these fields are used at all by pulpcore.

`validate. The pulpcore provided downloaders do some validation, but are unaware of the Remote.validate value. If this field is used, it must be used by the plugin. Therefore, the plugin should be the one to add it if they want it.

Associated revisions

Revision 9e6e5d36 View on GitHub
Added by amacdona@redhat.com 7 months ago

Remove unused field Remote.validate

This field was intended for plugin use, but so far plugins validate
unconditionally. For now, we remove the field from core but plugins can
add it on their own if they have a use for it.

https://pulp.plan.io/issues/4714
fixes #4714

History

#1 Updated by amacdona@redhat.com 9 months ago

To expand on this, some of these fields could be semi-implemented by pulpcore. For instance, policy should not be included on the remote, but policy choices should be defined by pulpcore and set on the plugin remote if they decide to have a policy field.

#2 Updated by amacdona@redhat.com 9 months ago

  • Description updated (diff)

#3 Updated by dkliban@redhat.com 9 months ago

  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes

#4 Updated by amacdona@redhat.com 9 months ago

This should be considered a "backwards incompatible" change and should be included in a pulpcore-plugin release with with a version bump (not just an rc bump).

#5 Updated by ipanova@redhat.com 9 months ago

  • Sprint set to Sprint 52

#6 Updated by rchan 9 months ago

  • Sprint changed from Sprint 52 to Sprint 53

#7 Updated by amacdona@redhat.com 8 months ago

  • Sprint changed from Sprint 53 to Sprint 54

#8 Updated by ttereshc 7 months ago

  • Sprint changed from Sprint 54 to Sprint 55

#9 Updated by bmbouter 7 months ago

  • Subject changed from Remove extra fields from Master Remote object to Remove the 'validate' field from Master Remote object
  • Description updated (diff)

Rewriting to remove mention of 'policy' which is being fixed with https://pulp.plan.io/issues/4990 instead.

#10 Updated by amacdona@redhat.com 7 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to amacdona@redhat.com

#11 Updated by amacdona@redhat.com 7 months ago

  • Status changed from ASSIGNED to POST

#12 Updated by amacdona@redhat.com 7 months ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#13 Updated by bmbouter about 1 month ago

  • Sprint/Milestone set to 3.0.0

#14 Updated by bmbouter about 1 month ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF