Project

Profile

Help

Issue #5905

closed

ansible-galaxy collection publish fails

Added by bmbouter almost 3 years ago. Updated over 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 98
Quarter:

Description

In a correctly configured pulp_ansible environment I try to upload a collection via ansible-galaxy (also correctly configured) and it fails.

1. Make a repository, e.g. http POST :80/pulp/api/v3/repositories/ansible/ansible/ name=foo
2. Make a distribution for that repository, e.g. http POST :80/pulp/api/v3/distributions/ansible/ansible/ name='baz' base_path='foo' repository=/pulp/api/v3/repositories/ansible/ansible/53025e9e-9f30-4086-8214-8811028a396f/
3. Try to upload:

(pulp) [vagrant@pulp3-source-fedora31 ~]$ ansible-galaxy collection publish bmbouter-testing-1.0.0.tar.gz -vvvv
ansible-galaxy 2.9.2
  config file = /home/vagrant/.ansible.cfg
  configured module search path = ['/home/vagrant/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/local/lib/pulp/lib64/python3.7/site-packages/ansible
  executable location = /usr/local/lib/pulp/bin/ansible-galaxy
  python version = 3.7.4 (default, Aug 12 2019, 14:45:07) [GCC 9.1.1 20190605 (Red Hat 9.1.1-2)]
Using /home/vagrant/.ansible.cfg as config file
Initial connection to galaxy_server: http://localhost:24817/pulp_ansible/galaxy/foo
Opened /home/vagrant/.ansible/galaxy_token
Calling Galaxy at http://localhost:24817/pulp_ansible/galaxy/foo
Opened /home/vagrant/.ansible/galaxy_token
Calling Galaxy at http://localhost:24817/pulp_ansible/galaxy/foo/api
Found API version 'v1, v2' with Galaxy server default (http://localhost:24817/pulp_ansible/galaxy/foo/api)
Publishing collection artifact '/home/vagrant/bmbouter-testing-1.0.0.tar.gz' to default http://localhost:24817/pulp_ansible/galaxy/foo/api
Opened /home/vagrant/.ansible/galaxy_token
Calling Galaxy at http://localhost:24817/pulp_ansible/galaxy/foo/api/v2/collections/
ERROR! Error when publishing collection to default (http://localhost:24817/pulp_ansible/galaxy/foo/api) (HTTP Code: 400, Message: Bad Request Code: Unknown)
Actions #1

Updated by bmbouter almost 3 years ago

  • Description updated (diff)
Actions #2

Updated by bmbouter almost 3 years ago

  • Subject changed from ansible-galaxy collection publish is fails to ansible-galaxy collection publish fails
Actions #3

Updated by bmbouter over 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bmbouter
  • Sprint set to Sprint 65

Fixing as part of adding a test which is already on the sprint.

Actions #4

Updated by bmbouter over 2 years ago

  • Status changed from ASSIGNED to POST

Added by bmbouter over 2 years ago

Revision 4cc4aac8

Fix collection upload and add a test for it

https://pulp.plan.io/issues/5905 closes #5905

https://pulp.plan.io/issues/5931 closes #5931

Actions #5

Updated by bmbouter over 2 years ago

  • Status changed from POST to MODIFIED
Actions #6

Updated by shanemcd over 2 years ago

Greetings. I am using the following versions of pulpcore and pulp-ansible, but am still seeing this issue:

[galaxy@62e71ce0f767 /]$ pip list install | grep pulp
pulp-ansible                    0.2.0b11
pulpcore                        3.2.1
Actions #7

Updated by bmbouter over 2 years ago

  • Status changed from MODIFIED to NEW

I'm bringing back to NEW to reopen the issue for confirmation the bug is fixed or present on master.

Actions #8

Updated by rchan about 2 years ago

Sounds like this issue can be closed? It's been open for a long time and no further reports of it being a problem or needing to be addressed.

Actions #9

Updated by bmbouter about 2 years ago

  • Assignee deleted (bmbouter)

Unassigning from myself since I am not actively working on this.

Actions #10

Updated by fao89 over 1 year ago

  • Sprint changed from Sprint 65 to Sprint 90
Actions #11

Updated by rchan over 1 year ago

  • Sprint changed from Sprint 90 to Sprint 91
Actions #12

Updated by rchan over 1 year ago

  • Sprint changed from Sprint 91 to Sprint 92
Actions #13

Updated by rchan over 1 year ago

  • Sprint changed from Sprint 92 to Sprint 93
Actions #14

Updated by rchan over 1 year ago

  • Sprint changed from Sprint 93 to Sprint 94
Actions #15

Updated by rchan over 1 year ago

  • Sprint changed from Sprint 94 to Sprint 95
Actions #16

Updated by rchan over 1 year ago

  • Sprint changed from Sprint 95 to Sprint 96
Actions #17

Updated by rchan over 1 year ago

  • Sprint changed from Sprint 96 to Sprint 97
Actions #18

Updated by rchan over 1 year ago

  • Sprint changed from Sprint 97 to Sprint 98
Actions #19

Updated by bmbouter over 1 year ago

I tried to reproduce this locally, but I could not.

Actions #20

Updated by gerrod over 1 year ago

  • Status changed from NEW to CLOSED - WORKSFORME

I could not reproduce this locally.

Also available in: Atom PDF