Project

Profile

Help

Task #4312

closed

Switch Travis-CI to use Pulp 3 installer

Added by kersom over 5 years ago. Updated about 4 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
Sprint:
Sprint 50
Quarter:

Description

Currently Travis-CI relies on a series of scripts to install Pulp 3.
Switching to Pulp 3 installer on Travis will be beneficial to test the installer, and sync changes with different environments.
Today I tested Pulp against an installation using the ansible-pulp3 and few tests failed locally, due to a missing setting already present on Travis.

See: 4302.


Related issues

Related to Pulp - Task #4189: Extend Travis build+publish pipeline to build, test, and publish vanilla core process images to quay.ioCLOSED - WONTFIX

Actions
Related to Pulp - Issue #7063: pulp_installer adds a redis PPA on all Ubuntu releasesCLOSED - CURRENTRELEASEmdepaulo@redhat.comActions
Blocked by Pulp - Issue #4510: Ansible roles: Separate installing postgres from configuring itCLOSED - CURRENTRELEASEamacdona@redhat.comActions
Actions #1

Updated by daviddavis over 5 years ago

  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes

I think other plugins need to be updated too. Part of this task should be to open issues for other plugins and the plugin template.

Actions #2

Updated by daviddavis over 5 years ago

  • Tags Pulp 3 RC Blocker added
Actions #3

Updated by ttereshc over 5 years ago

  • Sprint set to Sprint 49
Actions #4

Updated by amacdona@redhat.com over 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to amacdona@redhat.com

Added by amacdona@redhat.com over 5 years ago

Revision 82516771 | View on GitHub

Various fixes to support ubuntu install

This is a necessary pre-step to work with travis. https://pulp.plan.io/issues/4312 re: #4312

Added by amacdona@redhat.com over 5 years ago

Revision 82516771 | View on GitHub

Various fixes to support ubuntu install

This is a necessary pre-step to work with travis. https://pulp.plan.io/issues/4312 re: #4312

Actions #5

Updated by amacdona@redhat.com over 5 years ago

  • Blocked by Issue #4510: Ansible roles: Separate installing postgres from configuring it added
Actions #6

Updated by amacdona@redhat.com over 5 years ago

  • Related to Task #4189: Extend Travis build+publish pipeline to build, test, and publish vanilla core process images to quay.io added
Actions #7

Updated by rchan over 5 years ago

  • Sprint changed from Sprint 49 to Sprint 50
Actions #8

Updated by amacdona@redhat.com over 5 years ago

  • Status changed from ASSIGNED to POST

Added by amacdona@redhat.com about 5 years ago

Revision 35b7f3ed | View on GitHub

Use ansible to install on travis

Do not test python 3.6 on maria. We may need to add this back at some point, but for now, running the 3.6 and 3.7 against both databases seems like overkill and uses too many concurrent jobs.

Required PR: https://github.com/pulp/ansible-pulp3/pull/94

re #4312

Actions #9

Updated by amacdona@redhat.com about 5 years ago

  • Status changed from POST to MODIFIED
Actions #10

Updated by daviddavis about 5 years ago

  • Sprint/Milestone set to 3.0.0
Actions #11

Updated by bmbouter about 5 years ago

  • Tags deleted (Pulp 3, Pulp 3 RC Blocker)
Actions #12

Updated by bmbouter over 4 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE
Actions #13

Updated by bmbouter about 4 years ago

  • Category set to Installer - Moved to GitHub issues
  • Tags deleted (Pulp 3 installer)
Actions #14

Updated by mdepaulo@redhat.com almost 4 years ago

  • Related to Issue #7063: pulp_installer adds a redis PPA on all Ubuntu releases added

Also available in: Atom PDF