Project

Profile

Help

Issue #1394

export distributor does not allow 'relative_url' config override

Added by cduryee almost 6 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.8.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

The yum export distributor uses the ExportRepoPublisher to perform an export. This supports a 'relative_url' config option which is extremely useful since setting the relative_url will create delicious listing files, whereas setting the 'export_dir' alone will not.

However, the export distributor's config checker does not think 'relative_url' is a valid configuration key. This patch seems to do the trick, and allows 'relative_url' to be set on the exporter:

--- /tmp/constants.py.old       2015-12-02 17:19:18.509000000 -0500
+++ /usr/lib/python2.7/site-packages/pulp_rpm/common/constants.py       2015-12-02 15:58:30.320000000 -0500
@@ -134,9 +134,10 @@
 SKIP_KEYWORD = 'skip'
 START_DATE_KEYWORD = 'start_date'
 GENERATE_SQLITE_KEYWORD = 'generate_sqlite'
+RELATIVE_URL_KEYWORD = 'relative_url'
 EXPORT_OPTIONAL_CONFIG_KEYS = (END_DATE_KEYWORD, ISO_PREFIX_KEYWORD, SKIP_KEYWORD,
                                EXPORT_DIRECTORY_KEYWORD, START_DATE_KEYWORD, ISO_SIZE_KEYWORD,
-                               GENERATE_SQLITE_KEYWORD)
+                               GENERATE_SQLITE_KEYWORD, RELATIVE_URL_KEYWORD)

 EXPORT_HTTP_DIR = '/var/lib/pulp/published/http/exports/repo'
 EXPORT_HTTPS_DIR = '/var/lib/pulp/published/https/exports/repo'

Can this be fixed in the next Pulp release? It would help me out immensely since I can then rely on Pulp to create exports with listing files :)


Related issues

Blocks RPM Support - Story #1419: As a pulp-admin user, I can set relative-url on the export distributorCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 1d959a6e View on GitHub
Added by semyers almost 6 years ago

Add relative_url as a valid config key for export distributor

https://pulp.plan.io/issues/1394 fixes #1394

History

#1 Updated by dkliban@redhat.com almost 6 years ago

Chris is blocked by this issue. I said we could release it with 2.7.2. Let's make it high priority.

#2 Updated by jortel@redhat.com almost 6 years ago

  • Priority changed from Normal to High
  • Triaged changed from No to Yes

#3 Updated by jortel@redhat.com almost 6 years ago

  • Platform Release set to 2.8.0

#4 Updated by semyers almost 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to semyers

#5 Updated by semyers almost 6 years ago

This does appear to be an easy fix, but there's a lack of coverage on those optional config keys that I plan to address in a separate issue once this is taken care of.

#6 Updated by semyers almost 6 years ago

  • Blocks Story #1419: As a pulp-admin user, I can set relative-url on the export distributor added

#7 Updated by semyers almost 6 years ago

I found the tests and added to them, but I'm double checking with beav to see if he needs this for 2.7 as mentioned in an earlier comment or if the 2.8 target release is correct.

#8 Updated by semyers almost 6 years ago

2.8 confirmed

#9 Updated by semyers almost 6 years ago

  • Status changed from ASSIGNED to POST

#10 Updated by semyers almost 6 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#11 Updated by rbarlow almost 6 years ago

  • Status changed from MODIFIED to 5

#12 Updated by dkliban@redhat.com over 5 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#13 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF