Project

Profile

Help

Issue #1061

qpidtoollibs has moved from python-qpid-qmf to qpid-tools

Added by dkliban@redhat.com over 5 years ago. Updated 5 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
2.7.1
OS:
RHEL 6
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

The qpid team has moved the qpidtoollibs Python package from python-qpid-qmf to qpid-tools. This means that our pulp-server-qpid package group no longer installs a working system, as the famous migration 0009 will fail:

==> dev: Halting migrations due to a migration failure.
==> dev: Migration 0009 did not run because the python package qpidtoollibs is not installed. Please install qpidtoollibs and rerun the migrations. See http://pulp-user-guide.readthedocs.org/en/2.4-release/troubleshooting.html#qpidtoollibs-is-not-installed for more information.
==> dev: Traceback (most recent call last):
==> dev:   File "/home/vagrant/devel/pulp/server/pulp/server/db/manage.py", line 159, in main
==> dev:     return _auto_manage_db(options)
==> dev:   File "/home/vagrant/devel/pulp/server/pulp/server/db/manage.py", line 220, in _auto_manage_db
==> dev:     migrate_database(options)
==> dev:   File "/home/vagrant/devel/pulp/server/pulp/server/db/manage.py", line 91, in migrate_database
==> dev:     update_current_version=not options.test)
==> dev:   File "/home/vagrant/devel/pulp/server/pulp/server/db/migrate/models.py", line 157, in apply_migration
==> dev:     migration.migrate()
==> dev:   File "/home/vagrant/devel/pulp/server/pulp/server/db/migrations/0009_qpid_queues.py", line 56, in migrate
==> dev:     raise Exception(msg)
==> dev: Exception: Migration 0009 did not run because the python package qpidtoollibs is not installed. Please install qpidtoollibs and rerun the migrations. See http://pulp-user-guide.readthedocs.org/en/2.4-release/troubleshooting.html#qpidtoollibs-is-not-installed for more information.

Deliverables:

  • Adjust the troubleshooting guide referenced in the error message above to recommend the qpid-tools package instead of the python-qpid-qmf package
  • Adjust the pulp-server-qpid package group to require qpid-tools instead of python-qpid-qmf

Note: Currently the qpidtoollibs package is missing from both packages in Fedora 21, so there is no way for users to deploy a working Pulp with qpid at the moment.

Associated revisions

Revision f42a4b04 View on GitHub
Added by dkliban@redhat.com almost 5 years ago

Updates comps.xml to use qpid-tools instead of python-qpid-qmf

https://pulp.plan.io/issues/1061 closes #1061

Revision f42a4b04 View on GitHub
Added by dkliban@redhat.com almost 5 years ago

Updates comps.xml to use qpid-tools instead of python-qpid-qmf

https://pulp.plan.io/issues/1061 closes #1061

History

#1 Updated by rbarlow over 5 years ago

  • Subject changed from Add qpid-tools to the pulp-server-qpid install group to qpidtoollibs has moved from python-qpid-qmf to qpid-tools
  • Description updated (diff)

I recommend high/high, though I'll leave that decision ultimately to the triage team.

#2 Updated by Skullman over 5 years ago

My understanding is that I should be able to workaround it if I install qpid-tools, however I got this error regardless the fact that I have all the packages:

[root@machine ~]# yum install python-qpid-qmf qpid-tools python-qpid
Loaded plugins: pulp-profile-update
Package python-qpid-qmf-0.28-29.fc21.x86_64 already installed and latest version
Package qpid-tools-0.30-3.fc21.x86_64 already installed and latest version
Package python-qpid-0.30-2.fc21.noarch already installed and latest version
Nothing to do
[root@machine ~]# su - apache -s /bin/sh -c pulp-manage-db
Mongo database for connection is version 2.4.13
Loading content types.
Loading type descriptors [puppet.json, iso_support.json, docker.json, rpm_support.json]
Parsing type descriptors
Validating type descriptor syntactic integrity
Validating type descriptor semantic integrity
Updating the database with types [puppet_module, iso, docker_image, distribution, drpm, erratum, package_group, package_category, package_environment, rpm, srpm, yum_repo_metadata_file]
Content types loaded.
Ensuring the admin role and user are in place.
Admin role and user are in place.
Beginning database migrations.
Applying pulp.server.db.migrations version 9
Migration 0009 did not run because the python package qpidtoollibs is not installed. Please install qpidtoollibs and rerun the migrations. See http://pulp-user-guide.readthedocs.org/en/2.4-release/troubleshooting.html#qpidtoollibs-is-not-installed for more information.
Applying migration pulp.server.db.migrations.0009_qpid_queues failed.

Halting migrations due to a migration failure.
Migration 0009 did not run because the python package qpidtoollibs is not installed. Please install qpidtoollibs and rerun the migrations. See http://pulp-user-guide.readthedocs.org/en/2.4-release/troubleshooting.html#qpidtoollibs-is-not-installed for more information.
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 159, in main
    return _auto_manage_db(options)
  File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 220, in _auto_manage_db
    migrate_database(options)
  File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 91, in migrate_database
    update_current_version=not options.test)
  File "/usr/lib/python2.7/site-packages/pulp/server/db/migrate/models.py", line 157, in apply_migration
    migration.migrate()
  File "/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0009_qpid_queues.py", line 56, in migrate
    raise Exception(msg)
Exception: Migration 0009 did not run because the python package qpidtoollibs is not installed. Please install qpidtoollibs and rerun the migrations. See http://pulp-user-guide.readthedocs.org/en/2.4-release/troubleshooting.html#qpidtoollibs-is-not-installed for more information.

Fedora 21 x86_64 - newly installed machine containing only Pulp.

#3 Updated by rbarlow over 5 years ago

Hello Skullman! (Cool nick!)

Unfortunately the upstream Fedora 21 packages are currently broken, which is out of our control. I was told the fix for this issue would land in the F21 stable repositories today. If it's not there yet (I haven't checked) I think you can get the fix in the updates-testing repository.

Sorry for the confusion!

#4 Updated by bmbouter over 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bmbouter
  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes

Work with Irina on Qpid team to get the deps published as needed.

#5 Updated by bmbouter over 5 years ago

  • Platform Release set to 2.7.0

#6 Updated by bmbouter about 5 years ago

  • Status changed from ASSIGNED to CLOSED - NOTABUG

This was fixed by the Qpid team already. Rather than adjusting the comps.xml in any way, the best thing we could do is prevent these issues from occurring by testing the testing repo in fedora using Jenkins before they are promoted to fedora updates. That work is tracked by #1083.

#7 Updated by bmbouter almost 5 years ago

  • Status changed from CLOSED - NOTABUG to ASSIGNED
  • OS set to RHEL 7

I believe this was fixed in fedora, but not in EL7 and possibly EL6. I'm reopening based on that.

#8 Updated by dkliban@redhat.com almost 5 years ago

I have just confirmed that this is still broken in EL6. It does work on Fedora 22, 23 and EL7.

#9 Updated by dkliban@redhat.com almost 5 years ago

  • OS changed from RHEL 7 to RHEL 6

#10 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from ASSIGNED to MODIFIED
  • % Done changed from 0 to 100

#11 Updated by dkliban@redhat.com almost 5 years ago

  • Platform Release changed from 2.7.0 to 2.7.1

#12 Updated by bmbouter almost 5 years ago

  • Has duplicate Issue #1396: RHEL 7 install doc misses RPM, error throws link to wrong doc afterward added

#13 Updated by bmbouter almost 5 years ago

  • Has duplicate deleted (Issue #1396: RHEL 7 install doc misses RPM, error throws link to wrong doc afterward)

#14 Updated by bmbouter almost 5 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#15 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF