Project

Profile

Help

Issue #1396

RHEL 7 install doc misses RPM, error throws link to wrong doc afterward

Added by kfiresmith almost 5 years ago. Updated 4 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.7.0
Platform Release:
2.7.1
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Easy Fix, Pulp 2
Sprint:
Quarter:

Description

Folks,
The Server installation doc here: https://pulp.readthedocs.org/en/latest/user-guide/installation.html#server misses the required package "qpid-tools". This becomes apparent when one attempts to initialize the Pulp Mongo database:

Halting migrations due to a migration failure.
Migration 0009 did not run because the python package qpidtoollibs is not installed. Please install qpidtoollibs and rerun the migrations. See http://pulp-user-guide.readthedocs.org/en/2.4-release/troubleshooting.html#qpidtoollibs-is-not-installed for more information.
Traceback (most recent call last):

Unfortunately the link provided in the error (a practice new users like myself greatly appreciate, btw!) is stale and points to 2.4 troubleshooting docs that I have observed won't fix RHEL 7. The "/latest/" docs do however provide the correct guidance on fixing the issue (install qpid-tools).

So I guess my request is kind of twofold:
1. Update the docs to have the user install qpid-tools if using RHEL
2. Update the Pulp source code to use the "/latest/" doc link that provides the fix for this issue: https://pulp.readthedocs.org/en/latest/user-guide/troubleshooting.html#qpidtoollibs-is-not-installed

Thanks a bunch!
- Kodiak Firesmith

Associated revisions

Revision c84c9e99 View on GitHub
Added by dkliban@redhat.com almost 5 years ago

Removes URLs from migration 0009 error messages

https://pulp.plan.io/issues/1396 closes #1396

Revision c84c9e99 View on GitHub
Added by dkliban@redhat.com almost 5 years ago

Removes URLs from migration 0009 error messages

https://pulp.plan.io/issues/1396 closes #1396

History

#1 Updated by bmbouter almost 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Thank you for the bug report. This bug is actually a problem with our comps.xml definition which is tracked as issue #1061. Since the root cause is tracked there I'm going to close this as a duplicate. Even still, I appreciate the detailed report.

That change is expected to be included with 2.7.1. From there the statement below already in the docs will ensure they have qpid-tools installed.

sudo yum groupinstall pulp-server-qpid

#2 Updated by bmbouter almost 5 years ago

  • Is duplicate of Issue #1061: qpidtoollibs has moved from python-qpid-qmf to qpid-tools added

#3 Updated by kfiresmith almost 5 years ago

bmbouter wrote:

Thank you for the bug report. This bug is actually a problem with our comps.xml definition which is tracked as issue #1061. Since the root cause is tracked there I'm going to close this as a duplicate. Even still, I appreciate the detailed report.

That change is expected to be included with 2.7.1. From there the statement below already in the docs will ensure they have qpid-tools installed.

[...]

My only remaining qualm is that the pulp-server(?) code still throws an error message pointing to an older version (2.4) of the docs rather than the one in the "/latest/" version of the docs which doesn't resolve the problem. I didn't see updating the pulp-server code as a deliverable in the issue# this one is a duplicate of.

Thanks very much!
- Kodiak

#4 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from CLOSED - DUPLICATE to POST

Good point. I submitted a PR to remove the links from the error messages.

https://github.com/pulp/pulp/pull/2224

#5 Updated by bmbouter almost 5 years ago

  • Is duplicate of deleted (Issue #1061: qpidtoollibs has moved from python-qpid-qmf to qpid-tools)

#6 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#7 Updated by dkliban@redhat.com almost 5 years ago

  • Platform Release set to 2.7.1

#8 Updated by mhrivnak almost 5 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE
  • Triaged changed from No to Yes

#9 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

#10 Updated by bmbouter 4 months ago

  • Category deleted (23)

Please register to edit this issue

Also available in: Atom PDF