Project

Profile

Help

Issue #9301

closed

Users running into timeouts with error messages that are unhelpful

Added by dalley about 1 year ago. Updated 10 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 106
Quarter:

Description

See attached bugzilla.

There was some additional discussion with a separate upstream user, who was running into this same issue: https://riot.im/app/#/room/#pulp:matrix.org/$xyV5D40cKUjqOYK7n7fk3J8v1RAqsu1KfafcYl968v8

The user had hypothesized that that maybe the "retries" were all counting towards the same "total timeout", but we have no confirmation of this.

This upstream aiohttp issue includes the same traceback and might provide some insight: https://github.com/aio-libs/aiohttp/issues/5239#issuecomment-727544671

I did also notice that we use the same ClientSession for all of a downloader's requests, that might be relevant: https://github.com/pulp/pulpcore/blob/master/pulpcore/download/http.py#L161-L163


Related issues

Copied to Pulp - Backport #9491: Backport #9301 "Users running into timeouts with error messages that are unhelpful" to 3.14.zCLOSED - CURRENTRELEASEipanova@redhat.com

Actions
Actions #1

Updated by dalley about 1 year ago

  • Description updated (diff)
Actions #2

Updated by dkliban@redhat.com about 1 year ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 104
Actions #3

Updated by dalley about 1 year ago

  • Priority changed from Normal to High

Assigning high because of multiple reports + BZ

Actions #4

Updated by lmjachky about 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to lmjachky
Actions #5

Updated by rchan about 1 year ago

  • Sprint changed from Sprint 104 to Sprint 105
Actions #6

Updated by lmjachky about 1 year ago

  • Status changed from ASSIGNED to NEW
Actions #7

Updated by lmjachky about 1 year ago

  • Assignee deleted (lmjachky)
Actions #8

Updated by lmjachky about 1 year ago

Just to note some findings:

  1. The URLs which can be used for testing are: http://yum.oracle.com/repo/OracleLinux/OL8/appstream/x86_64/ and https://cdn.redhat.com/content/eus/rhel/server/7/7.7/x86_64/os.
  2. You can also use python bindings to create a new remote object with certificates like this:
rpm_remote = rpm_remote_api.create({
    'name': RPM_REPO_NAME,
    'url': "http://yum.oracle.com/repo/OracleLinux/OL8/appstream/x86_64/",
    'policy': 'immediate',
    'client_cert': open("/home/vagrant/devel/13_sept_certs/rhcdn.crt", mode='r').read(),
    'client_key': open("/home/vagrant/devel/13_sept_certs/rhcdn.key", mode='r').read(),
    'tls_validation': False,
})

  1. on_demand syncing does not trigger any erroneous behaviour.
  2. immediate syncing ended up with "No space left on device" errors on my machine (not sure whether this error was caused by insufficient RAM space or regular disk space).
Actions #9

Updated by rchan about 1 year ago

  • Sprint changed from Sprint 105 to Sprint 106
Actions #10

Updated by dkliban@redhat.com about 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to dkliban@redhat.com
Actions #11

Updated by pulpbot 12 months ago

  • Status changed from ASSIGNED to POST
Actions #12

Updated by ttereshc 12 months ago

  • Copied to Backport #9491: Backport #9301 "Users running into timeouts with error messages that are unhelpful" to 3.14.z added
Actions #14

Updated by ipanova@redhat.com 12 months ago

  • Assignee changed from dkliban@redhat.com to ipanova@redhat.com

Added by ipanova@redhat.com 12 months ago

Revision 8a1db3b9

Improved messaging around timeout requests.

closes #9301

Actions #15

Updated by ipanova@redhat.com 12 months ago

  • Status changed from POST to MODIFIED
Actions #16

Updated by pulpbot 10 months ago

  • Sprint/Milestone set to 3.17.0
Actions #17

Updated by pulpbot 10 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF