Project

Profile

Help

Issue #7353

bindings for ansible collection are too strict on documentation field

Added by jsherril@redhat.com 4 months ago. Updated 3 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Sprint 80
Quarter:

Description

When syncing:

url: "https://galaxy.ansible.com"

---
  collections:
  - robertdebock.rundeck_collection"

And then trying to fetch the ansible collection versions, using the bindings 'list' call, i get an error:

ArgumentError: invalid value for "documentation", must conform to the pattern (?-mix:^(?:[a-z0-9.-+])://(?:[^\s:@/]+(?::[^\s:@/])?@)?(?:(?:25[0-5]|2[0-4]\d|[0-1]?\d?\d)(?:.(?:25[0-5]|2[0-4]\d|[0-1]?\d?\d)){3}|[[0-9a-f:.]+]|(a-z¡-0-9?(?:.(?!-)[a-z¡-0-9-]{1,63}(?<!-)).(?!-)(?:[a-z¡--]{2,63}|xn--[a-z0-9]{1,59})(?<!-).?|localhost))(?::\d{2,5})?(?:[/?#][^\s])?\Z).

pulpcore=# select version,documentation from ansible_collectionversion;
 version |                                  documentation                                   
---------+----------------------------------------------------------------------------------
 1.0.4   | 
 1.0.3   | https://github.com/robertdebock/ansible-collection-rundeck/blob/master/README.md
 1.0.2   | https://github.com/robertdebock/ansible-collection-rundeck/blob/master/README.md
 1.0.1   | https://github.com/robertdebock/ansible-collection-rundeck/blob/master/README.md
 1.0.6   | https://github.com/robertdebock/ansible-collection-rundeck/blob/master/README.md
 1.0.5   | https://github.com/robertdebock/ansible-collection-rundeck/blob/master/README.md
 1.0.4   | https://github.com/robertdebock/ansible-collection-rundeck/blob/master/README.md
 1.0.0   | https://github.com/robertdebock/ansible-collection-rundeck/blob/master/README.md
 1.0.7   | https://github.com/robertdebock/ansible-collection-rundeck/blob/master/README.md
 1.0.3   | 
 1.0.2   | 
 1.0.5   | 
 1.0.0   | 
 1.0.1   | https://github.com/newswangerd/collection_demo
 1.0.10  | 
 1.0.6   | 
(16 rows)

It also looks like the homepage and issues field may have the same issue.


Related issues

Has duplicate Ansible Plugin - Issue #6860: Replace URLField with CharFieldCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 8eeeedaf View on GitHub
Added by Fabricio Aguiar 3 months ago

Replace URLField with CharField

https://pulp.plan.io/issues/7353 closes #7353

History

#1 Updated by jsherril@redhat.com 4 months ago

  • Tags Katello added

#2 Updated by fao89 3 months ago

  • Related to Issue #6860: Replace URLField with CharField added

#3 Updated by bmbouter 3 months ago

  • Sprint set to Sprint 80

This is a duplicate of this issue https://pulp.plan.io/issues/6860 We closed https://pulp.plan.io/issues/6860 and we will fix here.

Solution

Replace URLField with CharField.

Ensure it fixes the problem

Reproduce the issue as described here first, and then ensure the swap to the other field type fixes the problem.

#4 Updated by bmbouter 3 months ago

  • Related to deleted (Issue #6860: Replace URLField with CharField)

#5 Updated by bmbouter 3 months ago

  • Has duplicate Issue #6860: Replace URLField with CharField added

#6 Updated by fao89 3 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to fao89

#7 Updated by pulpbot 3 months ago

  • Status changed from ASSIGNED to POST

#8 Updated by Anonymous 3 months ago

  • Status changed from POST to MODIFIED

#9 Updated by fao89 3 months ago

  • Sprint/Milestone set to 0.3.0

#10 Updated by pulpbot 3 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF