Project

Profile

Help

Issue #6510

v3.serializers.CollectionVersionSerializer needs to include distro base_path in 'download_url'

Added by alikins 5 months ago. Updated about 1 month ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 73
Quarter:

Description

v3.serializers.CollectionVersionSerializer doesn't include distro base_path in the 'download_url' it creates.

At the moment, since there is only one AnsibleRepository and one AnsibleDistribution, this doesn't cause a problem. But once we have multiple repositories, the 'download_url' will need to include the AnsibleDistribution.base_path in the url.

For example, with the galaxy_ng pr at https://github.com/ansible/galaxy_ng/pull/84/ it is possible to use per distro api endpoints.

For now, pr #84 has a local CollectionVersionSerializer that adds base_path to the 'download_url' so the 'download_url' looks like:

"http://localhost:24816/pulp/content/alikins-stage-distro-base-path/alikins.collection_inspect.0.0.182.tar.gz",

That will allow galaxy_ng to provide download_urls for 'golden' distro artifacts and for other repos/distros.

Associated revisions

Revision 8b01f6ad View on GitHub
Added by Fabricio Aguiar 4 months ago

Updating v3 CollectionVersion download URL

https://pulp.plan.io/issues/6510 closes #6510

History

#1 Updated by sivel 4 months ago

The construction should also likely utilize ANSIBLE_CONTENT_HOSTNAME instead of CONTENT_ORIGIN like v2.views. GalaxyCollectionVersionDetail

Part of the problem is that CONTENT_ORIGIN isn't supposed to have a scheme according to the advice I have been given.

#2 Updated by fao89 4 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to fao89
  • Sprint set to Sprint 73

#3 Updated by pulpbot 4 months ago

  • Status changed from ASSIGNED to POST

#4 Updated by Anonymous 4 months ago

  • Status changed from POST to MODIFIED

#5 Updated by fao89 4 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#6 Updated by fao89 about 1 month ago

  • Sprint/Milestone set to 0.2.0

Please register to edit this issue

Also available in: Atom PDF