Project

Profile

Help

Task #6294

Add release automation to plugin_template

Added by bmbouter over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
Yes
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Motivation

Releasing Pulp3 is a manual process with 15 steps in many cases. We could automate this process, we should automate it in a way that lets any plugin release using these scripts.

Requirements

  • We need to handle releasing a z-release and a y-release as separate scripts that the release engineer would run.
  • When proceeding it should prompt the release engineer for confirmation as it makes various steps, e.g. creating the changelog or version bumps
  • We should use bump2version to bump the versions
  • It should make branches and tags
  • It should make the github release via it's API

Related issues

Has duplicate Ansible Plugin - Task #4864: Create a release process that includes bumpversionCLOSED - DUPLICATE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Task #6600: Automation should bump the versions and generate the changelogCLOSED - COMPLETE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bmbouter over 1 year ago

  • Tracker changed from Issue to Task
  • % Done set to 0

#2 Updated by dkliban@redhat.com over 1 year ago

  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes

#3 Updated by rchan over 1 year ago

  • Sprint Candidate deleted (Yes)

#4 Updated by bmbouter over 1 year ago

  • Description updated (diff)
  • Sprint Candidate set to No

#5 Updated by bmbouter over 1 year ago

  • Has duplicate Task #4864: Create a release process that includes bumpversion added

#6 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - DUPLICATE

#7 Updated by bmbouter over 1 year ago

  • Is duplicate of Task #6600: Automation should bump the versions and generate the changelog added

Please register to edit this issue

Also available in: Atom PDF