Project

Profile

Help

Issue #6286

closed

ansible-pulp sets the gid for pulp_user that is not the gid of pulp_group

Added by dkliban@redhat.com over 4 years ago. Updated almost 4 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 82
Quarter:

Description

The default installation creates a user called 'pulp' and the user's gid belongs to a group 'users'. However, the systemd unit file for pulpcore-worker processes has the user and group set to 'pulp'. The installer should set the gid of the pulp_user to that of the pulp_group id.


Related issues

Is duplicate of Pulp - Issue #7173: pulp_installer makes Pulp's files owned by group "users" rather than group "pulp"CLOSED - CURRENTRELEASEmdellwegActions
Actions #1

Updated by bmbouter over 4 years ago

I think it's traditional for an application creating a dedicated user to also create a dedicated group. Because of this, I expect the defaults of the ansible installer to install a 'pulp' user and a 'pulp' group and allow these names to be configurable. For the devel environment for example they need to be overridden to be vagrant:vagrant.

Note that the 'pulp' user may also need to be added to additional groups and we need a way to do that also. That is separate somewhat from this issue so if we want to handle it separately let me know. The need is for pulp_container for example, pulp needs to be in the 'buildah' group.

Actions #2

Updated by fao89 over 4 years ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 68
Actions #3

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 68 to Sprint 69
Actions #4

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 69 to Sprint 70
Actions #5

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 70 to Sprint 71
Actions #6

Updated by rchan about 4 years ago

  • Sprint changed from Sprint 71 to Sprint 72
Actions #7

Updated by bmbouter about 4 years ago

  • Category set to Installer - Moved to GitHub issues
  • Tags deleted (Pulp 3 installer)
Actions #8

Updated by rchan about 4 years ago

  • Sprint changed from Sprint 72 to Sprint 73
Actions #9

Updated by rchan about 4 years ago

  • Sprint changed from Sprint 73 to Sprint 74
Actions #10

Updated by rchan about 4 years ago

  • Sprint changed from Sprint 74 to Sprint 75
Actions #11

Updated by rchan about 4 years ago

  • Sprint changed from Sprint 75 to Sprint 76
Actions #12

Updated by rchan about 4 years ago

  • Sprint changed from Sprint 76 to Sprint 77
Actions #13

Updated by rchan almost 4 years ago

  • Sprint changed from Sprint 77 to Sprint 78
Actions #14

Updated by rchan almost 4 years ago

  • Sprint changed from Sprint 78 to Sprint 79
Actions #15

Updated by rchan almost 4 years ago

  • Sprint changed from Sprint 79 to Sprint 80
Actions #16

Updated by rchan almost 4 years ago

  • Sprint changed from Sprint 80 to Sprint 81
Actions #17

Updated by rchan almost 4 years ago

  • Sprint changed from Sprint 81 to Sprint 82
Actions #18

Updated by dkliban@redhat.com almost 4 years ago

  • Is duplicate of Issue #7173: pulp_installer makes Pulp's files owned by group "users" rather than group "pulp" added
Actions #19

Updated by dkliban@redhat.com almost 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Also available in: Atom PDF