Project

Profile

Help

Issue #6253

Chunked uploads don't work against S3

Added by daviddavis 8 months ago. Updated 6 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Backlog
Sprint:
Sprint 69
Quarter:

Description

The problem is that we're storing chunks in S3 and then trying to write to these files. I think we need to either:

  1. Store the chunks on the filesystem and then when the upload is done, move it to s3
  2. Store the chunks in S3 and pull them down whenever a new chunk comes in, write to them, and then upload them back into S3

Associated revisions

Revision 6a3efe7e View on GitHub
Added by Lubos Mjachky 7 months ago

Upload chunks to a local file system

As of now, every single chunk is going to be "uploaded" to a local file system instead of the defined default file storage.

In addition to that, the test test_delete_upload was refactored because it did not properly verify whether the committed upload was removed from the file system or not. It rather tested if the upload was deleted after sending an HTTP DELETE request.

closes #6253

History

#1 Updated by fao89 8 months ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 67

#2 Updated by rchan 8 months ago

  • Sprint changed from Sprint 67 to Sprint 68

#3 Updated by ipanova@redhat.com 8 months ago

  • Tags Backlog added

#4 Updated by lmjachky 8 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to lmjachky

#5 Updated by rchan 7 months ago

  • Sprint changed from Sprint 68 to Sprint 69

#6 Updated by pulpbot 7 months ago

  • Status changed from ASSIGNED to POST

#7 Updated by Anonymous 7 months ago

  • Status changed from POST to MODIFIED

#8 Updated by ttereshc 6 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE
  • Sprint/Milestone set to 3.3.0

Please register to edit this issue

Also available in: Atom PDF