Project

Profile

Help

Test #5506

Create a smoke test for RPM plugin sync performance

Added by dalley about 2 years ago. Updated over 1 year ago.

Status:
CLOSED - COMPLETE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Version:
Platform Release:
Tags:
Sprint:
Sprint 60
Quarter:

Description

We will be putting much effort and investigation on performance in the coming days. To facilitate this investigation, it would be useful to have some performance smoke tests which can quickly allow a developer to gauge whether something significant has changed in this regard, or to facilitate the investigation of performance generally.

It is not necessary for the tests to be rigidly reproducible over a long period of time. They are intended to be used more as a developer tool and not to run as part of the CI pipeline.

  • Sync CentOS 7 repository, on_demand
  • Sync CentOS 8 Appstream repository, on_demand
  • Sync CentOS 8 BaseOS repository, on_demand

In keeping with the goals mentioned, they shouldn't run in the CI pipeline in the general case, although it may be useful to have them enabled through a particular flag to run if needed.

Associated revisions

Revision 78675397 View on GitHub
Added by Fabricio Aguiar about 2 years ago

Adding performance tests

closes #5506 https://pulp.plan.io/issues/5506

History

#1 Updated by daviddavis about 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to fao89
  • Sprint set to Sprint 59

#2 Updated by rchan about 2 years ago

  • Sprint changed from Sprint 59 to Sprint 60

#3 Updated by fao89 about 2 years ago

  • Status changed from ASSIGNED to POST

#4 Updated by ttereshc about 2 years ago

  • Tags Pulp 3 RPM blocker added

#5 Updated by Anonymous about 2 years ago

  • Status changed from POST to MODIFIED

#6 Updated by dalley over 1 year ago

  • Sprint/Milestone set to Pulp RPM 3.3.0

#7 Updated by dalley over 1 year ago

  • Status changed from MODIFIED to CLOSED - COMPLETE
  • Sprint/Milestone deleted (Pulp RPM 3.3.0)

#8 Updated by bmbouter over 1 year ago

  • Tags deleted (Pulp 3 RPM blocker)

Please register to edit this issue

Also available in: Atom PDF