Project

Profile

Help

Issue #5332

closed

Provide content_ansible_collection_read method for ansible collections

Added by jsherril@redhat.com over 3 years ago. Updated about 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Sprint 58
Quarter:

Description

We need the ability to read ansible collection content similar to other content types ex: https://pulp-ansible.readthedocs.io/en/latest/restapi.html#operation/content_ansible_roles_read.

This particular api is present, but it doesn't appear to show up in the bindings.


Related issues

Copied from Ansible Plugin - Issue #5001: Provide content_ansible_collection_read method for ansible collectionsCLOSED - CURRENTRELEASEbmbouterActions
Actions #1

Updated by jsherril@redhat.com over 3 years ago

  • Copied from Issue #5001: Provide content_ansible_collection_read method for ansible collections added
Actions #2

Updated by jsherril@redhat.com over 3 years ago

  • Status changed from MODIFIED to NEW
Actions #3

Updated by jsherril@redhat.com over 3 years ago

The Api works:

GET /pulp/api/v3/content/ansible/collections/f98e7514-5340-4303-80b4-f81aa2343930/

but there seems to not be any way to access it in the bindings.

Actions #4

Updated by daviddavis over 3 years ago

  • Assignee deleted (bmbouter)
Actions #5

Updated by daviddavis over 3 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to daviddavis
Actions #6

Updated by daviddavis over 3 years ago

  • Status changed from ASSIGNED to NEW
  • Assignee deleted (daviddavis)
Actions #7

Updated by daviddavis about 3 years ago

I think the problem is that we're returning CollectionVersions from the /api/v3/content/ansible/collections/ endpoint. We probably need separate collection and collection versions endpoint.

Actions #8

Updated by bmbouter about 3 years ago

I believe this is a subset of https://pulp.plan.io/issues/5238

Actions #9

Updated by daviddavis about 3 years ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 58

To solve this problem, we should remove the collection viewsets and just show collection versions (/pulp/api/v3/content/ansible/collection_versions).

Actions #10

Updated by fao89 about 3 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to fao89
Actions #11

Updated by fao89 about 3 years ago

  • Status changed from ASSIGNED to POST

Added by Fabricio Aguiar about 3 years ago

Revision 163f2eaa

content endpoint collection_versions

closes #5332 https://pulp.plan.io/issues/5332

Actions #12

Updated by Anonymous about 3 years ago

  • Status changed from POST to MODIFIED
Actions #13

Updated by ggainey over 2 years ago

  • Tags Katello added
  • Tags deleted (Katello-P2)
Actions #14

Updated by fao89 over 2 years ago

  • Sprint/Milestone set to 0.2.0
Actions #15

Updated by bmbouter about 2 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF