Project

Profile

Help

Issue #4524

Broken symlinks for subrepos are created during on_demand sync of kickstart trees

Added by ttereshc over 1 year ago. Updated 9 months ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
Yes
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 68
Quarter:

Description

1. Sync kickstart tree with on_demand policy.
2. Switch to immediate policy and re-sync.
3. Note that subrepos (HighAvailability, Addons) have broken symlinklinks because Pulp doesn't support subrepos but it seems like symlinks are still created for those during on_demand sync.

That causes Pulp to Pulp sync to fail.
Pulp should not create symlinks for the unsupported parts of kickstart trees.


Related issues

Related to RPM Support - Test #4525: Test broken symlinks for subrepos are created during on_demand sync of kickstart treesNEW<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by kersom over 1 year ago

  • Related to Test #4525: Test broken symlinks for subrepos are created during on_demand sync of kickstart trees added

#2 Updated by ttereshc over 1 year ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 50

This issue needs at least some investigation to figure out if it's a regression or no

#3 Updated by ttereshc over 1 year ago

Maybe worth checking if this fix helps to workaround/mitigate the problem https://pulp.plan.io/issues/4267, should be in master already.

#4 Updated by daviddavis over 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to daviddavis

#5 Updated by daviddavis over 1 year ago

  • Status changed from ASSIGNED to NEW

#6 Updated by daviddavis over 1 year ago

  • Status changed from NEW to ASSIGNED

#8 Updated by rchan over 1 year ago

  • Sprint changed from Sprint 50 to Sprint 51

#9 Updated by daviddavis over 1 year ago

  • Status changed from ASSIGNED to CLOSED - DUPLICATE

Talked with @dkliban who indicated that this is the same issue as #4603.

#10 Updated by daviddavis over 1 year ago

  • Is duplicate of Issue #4603: pulp_streamer streams decodes responses, but sends the 'gzip' Content-Encoding header added

#11 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

#12 Updated by dkliban@redhat.com over 1 year ago

  • Status changed from CLOSED - DUPLICATE to NEW
  • Assignee deleted (daviddavis)
  • Sprint changed from Sprint 51 to Sprint 56

I am reopening this issue because it is not a duplicate of https://pulp.plan.io/issues/4603 and is not fixed.

#13 Updated by dkliban@redhat.com over 1 year ago

  • Is duplicate of deleted (Issue #4603: pulp_streamer streams decodes responses, but sends the 'gzip' Content-Encoding header)

#14 Updated by rchan over 1 year ago

  • Sprint changed from Sprint 56 to Sprint 57

#15 Updated by ggainey over 1 year ago

  • Status changed from NEW to POST
  • Assignee set to ggainey
  • Groomed changed from No to Yes

PR submitted:

https://github.com/pulp/pulp/pull/3951

A script that reproduces, and shows the fix working, is here :

https://github.com/ggainey/pulp_startup/blob/master/4524/reproducer.bsh

#16 Updated by rchan over 1 year ago

  • Sprint changed from Sprint 57 to Sprint 58

#17 Updated by rchan about 1 year ago

  • Sprint changed from Sprint 58 to Sprint 59

#18 Updated by rchan about 1 year ago

  • Sprint changed from Sprint 59 to Sprint 60

#19 Updated by rchan about 1 year ago

  • Sprint changed from Sprint 60 to Sprint 61

#20 Updated by rchan about 1 year ago

  • Sprint changed from Sprint 61 to Sprint 62

#21 Updated by rchan 12 months ago

  • Sprint changed from Sprint 62 to Sprint 63

#22 Updated by rchan 11 months ago

  • Sprint changed from Sprint 63 to Sprint 64

#23 Updated by rchan 10 months ago

  • Sprint changed from Sprint 64 to Sprint 65

#24 Updated by rchan 10 months ago

  • Sprint changed from Sprint 65 to Sprint 66

#25 Updated by rchan 9 months ago

  • Sprint changed from Sprint 66 to Sprint 67

#26 Updated by ggainey 9 months ago

  • Status changed from POST to NEW

This appears to have fallen through a few cracks. The submitted PR 'fixes' the issue by fixing the links - the real problem is that subrepos aren't supported in pulp2, and the links shouldn't be there at all. Setting back to NEW, we need to address the actual problem.

#27 Updated by rchan 9 months ago

  • Sprint changed from Sprint 67 to Sprint 68

#28 Updated by ggainey 9 months ago

  • Status changed from NEW to CLOSED - WONTFIX

To unravel where we are with the bugzilla associated with this issue:

  • the original (breaking) behavior reported by users, was fixed and released with redmine issue #4603. That behavior was not the problem reported in this issue.
  • references to "on_demand repos have broken symlinks" in the original reports is largely 'normal behavior" - RPM symlinks are broken until the RPM has been requested, streamed to the user, and then the content moved by the streamer from its squid-cache to the 'correct' location
  • RHEL6 kickstart trees have sub-repos, which Pulp2 doesn't actually support
  • An on_demand RHEL6 kickstart tree will work as expected for the user. The only problem is that, for the non-RPM-content (ie, repomd.xml and friends), the streamer will return the correct content when requested, but will not move that content from its squid-cache to the appropriate location on disk.
  • immediate sync kstree-repos work fine
  • switching an on_demand kstree-repo to immediate and doing a --force-full works fine

The only symptom of this problem requires one to have a) on_demand sync'd b) a RHEL6 kickstart tree and c) requested the repomd.xml file of one of the subrepos therein (eg, HighAvailability, say), and then d) noticed that the symlink for that repomd.xml file is still broken after the streamer has run. The sync works, the kickstart works. If the streamer's squid-cache is deleted, then the next request for the metadata file will re-download it, since it was never moved out of the cache.

Given the low/zero impact on usability, and the place where we are in Pulp2's lifecycle, closing as WONTFIX.

Please register to edit this issue

Also available in: Atom PDF