Project

Profile

Help

Story #3874

Story #3657: As a user I can manage modulemd content

Support --validate importer option for Modulemd.

Added by jortel@redhat.com 9 months ago. Updated 5 days ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
% Done:

100%

Platform Release:
2.17.0
Blocks Release:
Backwards Incompatible:
No
Groomed:
Yes
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Add support for the --validate importer option. When (True), the importer will validate the stored file using the checksum during sync. When the stored file does not exist or has a checksum does not match, the file (document) associated with the Modulemd is updated.

Associated revisions

Revision 80ed7bc1 View on GitHub
Added by jortel@redhat.com 9 months ago

Add --validate support for modularity sync.
closes #3874

History

#1 Updated by jortel@redhat.com 9 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jortel@redhat.com

#2 Updated by jortel@redhat.com 9 months ago

  • Status changed from ASSIGNED to MODIFIED
  • % Done changed from 0 to 100

#3 Updated by ipanova@redhat.com 9 months ago

  • Platform Release set to 2.17.0

#4 Updated by ipanova@redhat.com 9 months ago

  • Platform Release changed from 2.17.0 to master

#5 Updated by ipanova@redhat.com 9 months ago

  • Platform Release deleted (master)

#6 Updated by ipanova@redhat.com 9 months ago

  • Platform Release set to 2.17.0

#7 Updated by ipanova@redhat.com 8 months ago

  • Status changed from MODIFIED to ON_QA

#8 Updated by ipanova@redhat.com 8 months ago

  • Status changed from ON_QA to CLOSED - CURRENTRELEASE

#9 Updated by bmbouter 5 days ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF