Project

Profile

Help

Issue #3534

Error syncing OSTree Repository

Added by steveh1138 about 2 years ago. Updated 12 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
3. High
Version - OSTree:
Platform Release:
2.17.1
Blocks Release:
Target Release - OSTree:
OS:
CentOS 7
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:
Sprint 38

Description

While suing Foreman/Katello 1.16.0 / 3.5.1 I get the following error attempting to sync the CentOS Atomic OSTree Repository.

PLP0000: MongoDB can only handle up to 8-byte ints

Here is the error outpout

{"pulp_tasks"=>
  [{"exception"=>nil,
    "task_type"=>"pulp.server.managers.repo.sync.sync",
    "_href"=>"/pulp/api/v2/tasks/37ff949b-7d12-44ff-8550-e558f739afa6/",
    "task_id"=>"37ff949b-7d12-44ff-8550-e558f739afa6",
    "tags"=>
     ["pulp:repository:cb22ae27-2f6c-4fe5-99d9-b0feec338dff",
      "pulp:action:sync"],
    "finish_time"=>"2018-03-27T15:55:33Z",
    "_ns"=>"task_status",
    "start_time"=>"2018-03-27T15:55:32Z",
    "traceback"=>
     "Traceback (most recent call last):\n  File \"/usr/lib/python2.7/site-packages/celery/app/trace.py\", line 240, in trace_task\n    R = retval = fun(*args, **kwargs)\n  File \"/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py\", line 527, in __call__\n    return super(Task, self).__call__(*args, **kwargs)\n  File \"/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py\", line 107, in __call__\n    return super(PulpTask, self).__call__(*args, **kwargs)\n  File \"/usr/lib/python2.7/site-packages/celery/app/trace.py\", line 438, in __protected_call__\n    return self.run(*args, **kwargs)\n  File \"/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py\", line 819, in sync\n    rebuild_content_unit_counts(repo_obj)\n  File \"/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py\", line 313, in rebuild_content_unit_counts\n    repository.save()\n  File \"/usr/lib/python2.7/site-packages/mongoengine/document.py\", line 367, in save\n    upsert=upsert, **write_concern)\n  File \"/usr/lib64/python2.7/site-packages/pymongo/collection.py\", line 2232, in update\n    check_keys, multi, manipulate, write_concern)\n  File \"/usr/lib64/python2.7/site-packages/pymongo/collection.py\", line 709, in _update\n    codec_options=self.codec_options).copy()\n  File \"/usr/lib64/python2.7/site-packages/pymongo/pool.py\", line 216, in command\n    self._raise_connection_failure(error)\n  File \"/usr/lib64/python2.7/site-packages/pymongo/pool.py\", line 343, in _raise_connection_failure\n    raise error\nOverflowError: MongoDB can only handle up to 8-byte ints\n",
    "spawned_tasks"=>[],
    "progress_report"=>
     {"ostree_web_importer"=>
       [{"num_success"=>1,
         "description"=>"Create/Open Local Repository",
         "step_type"=>"import_create_repository",
         "items_total"=>1,
         "state"=>"FINISHED",
         "error_details"=>[],
         "details"=>"",
         "num_failures"=>0,
         "step_id"=>"87967f1f-fc9f-4b0f-8970-4bbae8ff1ec9",
         "num_processed"=>1},
        {"num_success"=>0,
         "description"=>"Update Summary",
         "step_type"=>"import_summary",
         "items_total"=>1,
         "state"=>"FAILED",
         "error_details"=>
          [{"traceback"=>
             "  File \"/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py\", line 256, in process\n    self._process_block()\n\n  File \"/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py\", line 303, in _process_block\n    self.process_main()\n\n  File \"/usr/lib/python2.7/site-packages/pulp_ostree/plugins/importers/steps.py\", line 168, in process_main\n    repository.save()\n\n  File \"/usr/lib/python2.7/site-packages/mongoengine/document.py\", line 367, in save\n    upsert=upsert, **write_concern)\n\n  File \"/usr/lib64/python2.7/site-packages/pymongo/collection.py\", line 2232, in update\n    check_keys, multi, manipulate, write_concern)\n\n  File \"/usr/lib64/python2.7/site-packages/pymongo/collection.py\", line 709, in _update\n    codec_options=self.codec_options).copy()\n\n  File \"/usr/lib64/python2.7/site-packages/pymongo/pool.py\", line 216, in command\n    self._raise_connection_failure(error)\n\n  File \"/usr/lib64/python2.7/site-packages/pymongo/pool.py\", line 343, in _raise_connection_failure\n    raise error\n",
            "error"=>"MongoDB can only handle up to 8-byte ints"}],
         "details"=>"",
         "num_failures"=>1,
         "step_id"=>"114ac655-1450-4499-b22c-f904ecd6f7f7",
         "num_processed"=>1},
        {"num_success"=>0,
         "description"=>"Pull Remote Branches",
         "step_type"=>"import_pull",
         "items_total"=>1,
         "state"=>"NOT_STARTED",
         "error_details"=>[],
         "details"=>"",
         "num_failures"=>0,
         "step_id"=>"ccccb53f-1d3b-4b76-9b5a-b2ff66bd8846",
         "num_processed"=>0},
        {"num_success"=>0,
         "description"=>"Add Content Units",
         "step_type"=>"import_add_unit",
         "items_total"=>1,
         "state"=>"NOT_STARTED",
         "error_details"=>[],
         "details"=>"",
         "num_failures"=>0,
         "step_id"=>"ee65d371-f623-4c73-b4a4-04322e00701d",
         "num_processed"=>0},
        {"num_success"=>0,
         "description"=>"Clean",
         "step_type"=>"import_clean",
         "items_total"=>1,
         "state"=>"NOT_STARTED",
         "error_details"=>[],
         "details"=>"",
         "num_failures"=>0,
         "step_id"=>"a5b2ae02-00b5-470b-8fe1-bed81c7e22ef",
         "num_processed"=>0}]},
    "queue"=>"reserved_resource_worker-2@ussl-foreman.usanainc.com.dq",
    "state"=>"error",
    "worker_name"=>"reserved_resource_worker-2@ussl-foreman.usanainc.com",
    "result"=>nil,
    "error"=>
     {"code"=>"PLP0000",
      "data"=>{},
      "description"=>"MongoDB can only handle up to 8-byte ints",
      "sub_errors"=>[]},
    "_id"=>{"$oid"=>"5aba6973de37317496f9a7cb"},
    "id"=>"5aba6973de37317496f9a7cb"}],
 "contents_changed"=>true,
 "poll_attempts"=>{"total"=>2, "failed"=>1}}

I'm not sure which package versions you'll want to see so where is a dump of everything pulp I currently have installed

python-kombu-3.0.33-8.pulp.el7.noarch
rubygem-smart_proxy_pulp-1.3.0-1.el7.noarch
python-pulp-streamer-2.13.4-1.el7.noarch
pulp-puppet-tools-2.13.4-1.el7.noarch
python-pulp-ostree-common-1.2.1-3.el7.noarch
python-pulp-puppet-common-2.13.4-1.el7.noarch
python-pulp-docker-common-2.4.1-2.el7.noarch
python-isodate-0.5.0-4.pulp.el7.noarch
python-pulp-client-lib-2.13.4-1.el7.noarch
python-pulp-common-2.13.4-1.el7.noarch
python-pulp-rpm-common-2.13.4-1.el7.noarch
pulp-selinux-2.13.4-1.el7.noarch
pulp-puppet-plugins-2.13.4-1.el7.noarch
pulp-rpm-admin-extensions-2.13.4-1.el7.noarch
python-pulp-bindings-2.13.4-1.el7.noarch
pulp-katello-1.0.2-1.el7.noarch
pulp-ostree-plugins-1.2.1-3.el7.noarch
pulp-ostree-admin-extensions-1.2.1-3.el7.noarch
python-pulp-repoauth-2.13.4-1.el7.noarch
pulp-docker-plugins-2.4.1-2.el7.noarch
pulp-client-1.0-1.noarch
pulp-rpm-plugins-2.13.4-1.el7.noarch
pulp-server-2.13.4-1.el7.noarch
python-pulp-oid_validation-2.13.4-1.el7.noarch
pulp-admin-client-2.13.4-1.el7.noarch

When I posted this up in the Foreman support page they referenced me here as this error is related directly to pulp. Please let me know if you need any other information on my side and I would be more than happy to provide it.

Thank you!

Associated revisions

Revision 53d686fa View on GitHub
Added by jortel@redhat.com almost 2 years ago

Fix sync failures caused by unsupported metadata. closes #3534

Revision 90eb63ed View on GitHub
Added by jortel@redhat.com over 1 year ago

Fix sync failures caused by unsupported metadata. closes #3534

(cherry picked from commit 53d686fac7d115c5ee220e19f162b1096971e64f)

History

#1 Updated by daviddavis about 2 years ago

  • Project changed from File Support to OSTree Support

#2 Updated by ttereshc about 2 years ago

  • Description updated (diff)

Could you please provide your feed URL (where you synced your repository from)?

#3 Updated by steveh1138 about 2 years ago

Here is the OSTree repository I am attempting to sync

http://mirror.centos.org/centos/7/atomic/x86_64/repo/

#4 Updated by dalley almost 2 years ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes
  • Sprint set to Sprint 35

#5 Updated by mansari almost 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to mansari

#6 Updated by rchan almost 2 years ago

  • Sprint changed from Sprint 35 to Sprint 36

#7 Updated by rchan almost 2 years ago

  • Sprint changed from Sprint 36 to Sprint 37

#8 Updated by rchan almost 2 years ago

  • Status changed from ASSIGNED to NEW
  • Assignee deleted (mansari)

#9 Updated by jortel@redhat.com almost 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jortel@redhat.com

#10 Updated by jortel@redhat.com almost 2 years ago

  • Status changed from ASSIGNED to POST

#11 Updated by rchan almost 2 years ago

  • Sprint changed from Sprint 37 to Sprint 38

#12 Updated by jortel@redhat.com almost 2 years ago

  • Status changed from POST to MODIFIED

#13 Updated by dkliban@redhat.com over 1 year ago

  • Platform Release set to 2.17.1

#15 Updated by ttereshc over 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#17 Updated by bmbouter 12 months ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF