Project

Profile

Help

Issue #2096

Additional updateinfo.xml after second publish

Added by bmbouter over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Platform Release:
2.11.1
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 13
Quarter:

Description

Consider this reproducer:

pulp-admin rpm repo delete --repo-id zoo
pulp-admin orphan remove --all
pulp-admin rpm repo create --repo-id zoo --feed https://repos.fedorapeople.org/repos/pulp/pulp/fixtures/rpm/
pulp-admin rpm repo sync run --repo-id zoo

# Show 32 RPMs
pulp-admin rpm repo list

# Remove two RPMs, and show only 30 rpms after
pulp-admin rpm repo remove rpm --repo-id zoo --str-eq="sourcerpm=camel-0.1-1.src.rpm"
pulp-admin rpm repo remove rpm --repo-id zoo --str-eq="sourcerpm=cow-2.2-3.src.rpm"

# Show 30 RPMs now
pulp-admin rpm repo list

# verify that only 30 rpms are published
pulp-admin rpm repo publish run --repo-id zoo

# Do an incremental publish, publishing just 2 rpms
pulp-admin rpm repo sync run --repo-id zoo

Observe the two updateinfo files in the resulting output:

1f0179cb1e38298ac8b1f7380ad6cf515d73a7d25e0d36dab7b07b4fbdcd6c53-updateinfo.xml.gz
2036cf41fcde167770a2e794185b6bd7088797059a22cf8caa6accea0c4c9462-primary.xml.gz
45799989f67c83cd7f99facd3c133a1db6d01280718b373da7a388ca1a6c4843-filelists.xml.gz
5a926a84369bb7f67e92891eb2e89f2cb83d32cfb2b8f21cac538a037047792d-updateinfo.xml.gz
71c97177e5d31443497430b8b3030b4bde2a05a0be82a67292497d6b4100a38d-other.xml.gz
cfc8d64f15e00e2d49bc7f1db4a39a0b3e85f1aeaf6a9a7ca17b59d0ff4defbc-comps.xml
repomd.xml

I expected there to only be 1 updateinfo.xml.gz file since only 1 of them is listed int he repomd.xml

<?xml version="1.0" encoding="UTF-8"?>
<repomd xmlns="http://linux.duke.edu/metadata/repo" xmlns:rpm="http://linux.duke.edu/metadata/rpm"><revision>1469035113</revision>
<data type="filelists"><location href="repodata/45799989f67c83cd7f99facd3c133a1db6d01280718b373da7a388ca1a6c4843-filelists.xml.gz" /><timestamp>1469035113</timestamp><size>1986</size><checksum type="sha256">45799989f67c83cd7f99facd3c133a1db6d01280718b373da7a388ca1a6c4843</checksum><open-size>6353</open-size><open-checksum type="sha256">35021e134150dbf68cdb29807c57fe354a54d2525a012a76b57cc0af31a1f4fc</open-checksum></data>
<data type="other"><location href="repodata/71c97177e5d31443497430b8b3030b4bde2a05a0be82a67292497d6b4100a38d-other.xml.gz" /><timestamp>1469035113</timestamp><size>1820</size><checksum type="sha256">71c97177e5d31443497430b8b3030b4bde2a05a0be82a67292497d6b4100a38d</checksum><open-size>5374</open-size><open-checksum type="sha256">ab7c8ddda6305bc25b0f2514079d6f69fb2611aa23fa8c242853ed39c97ec7e8</open-checksum></data>
<data type="primary"><location href="repodata/2036cf41fcde167770a2e794185b6bd7088797059a22cf8caa6accea0c4c9462-primary.xml.gz" /><timestamp>1469035113</timestamp><size>3650</size><checksum type="sha256">2036cf41fcde167770a2e794185b6bd7088797059a22cf8caa6accea0c4c9462</checksum><open-size>31602</open-size><open-checksum type="sha256">79974d7eb3818578219df0a554a41623c89fa7c8e9c9ae38a14fe60edf4f9666</open-checksum></data>
<data type="updateinfo"><location href="repodata/5a926a84369bb7f67e92891eb2e89f2cb83d32cfb2b8f21cac538a037047792d-updateinfo.xml.gz" /><timestamp>1469035113</timestamp><size>421</size><checksum type="sha256">5a926a84369bb7f67e92891eb2e89f2cb83d32cfb2b8f21cac538a037047792d</checksum><open-size>1787</open-size><open-checksum type="sha256">ecd321951e0db408beab67a75c1f3e0ae5c77526a3a0d25be0b416fdfe993171</open-checksum></data>
<data type="group"><location href="repodata/cfc8d64f15e00e2d49bc7f1db4a39a0b3e85f1aeaf6a9a7ca17b59d0ff4defbc-comps.xml" /><timestamp>1469035113</timestamp><size>2357</size><checksum type="sha256">cfc8d64f15e00e2d49bc7f1db4a39a0b3e85f1aeaf6a9a7ca17b59d0ff4defbc</checksum></data>
</repomd>

Related issues

Has duplicate RPM Support - Issue #1045: incremental publish does not remove old updateinfo.xml CLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 16e9217c View on GitHub
Added by ttereshc almost 4 years ago

Do not keep the original updateinfo file after incremental publish

closes #2096 https://pulp.plan.io/issues/2096

Revision b705b9dd View on GitHub
Added by ttereshc almost 4 years ago

Check the search_tag before attempting to fast forward file

re #2096 https://pulp.plan.io/issues/2096

Revision b705b9dd View on GitHub
Added by ttereshc almost 4 years ago

Check the search_tag before attempting to fast forward file

re #2096 https://pulp.plan.io/issues/2096

History

#1 Updated by bmbouter over 4 years ago

  • Description updated (diff)

#2 Updated by ipanova@redhat.com over 4 years ago

I think it is normal behaviour to create updateinfo.xml with every operational publish.

#4 Updated by ttereshc over 4 years ago

I am not sure if it was made on purpose or not but Pulp pulishes the repo this way for quite a while. I believe 2.7 works this way.

#5 Updated by amacdona@redhat.com over 4 years ago

  • Severity changed from 2. Medium to 1. Low
  • Triaged changed from No to Yes

#7 Updated by bmbouter over 4 years ago

  • Has duplicate Issue #1045: incremental publish does not remove old updateinfo.xml added

#9 Updated by mhrivnak almost 4 years ago

I suspect it was not intentional to keep these, since pulp does not retain any of the other XML files from previous publishes. I think it is safe to make the behavior consistent and stop keeping old updateinfo files.

#10 Updated by bmbouter almost 4 years ago

+1 to not keeping these files around

#11 Updated by ipanova@redhat.com almost 4 years ago

  • Sprint/Milestone set to 31

#12 Updated by ipanova@redhat.com almost 4 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com

#13 Updated by ipanova@redhat.com almost 4 years ago

  • Assignee changed from ipanova@redhat.com to ttereshc

#14 Updated by ttereshc almost 4 years ago

  • Status changed from ASSIGNED to POST

#15 Updated by ttereshc almost 4 years ago

  • Status changed from POST to MODIFIED

#16 Updated by semyers almost 4 years ago

  • Platform Release set to 2.11.1

#17 Updated by semyers almost 4 years ago

  • Status changed from MODIFIED to 5

#19 Updated by semyers almost 4 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#21 Updated by bmbouter over 2 years ago

  • Sprint set to Sprint 13

#22 Updated by bmbouter over 2 years ago

  • Sprint/Milestone deleted (31)

#23 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF