Project

Profile

Help

Issue #1045

incremental publish does not remove old updateinfo.xml

Added by bcourt over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Low
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When an incremental publish is performed the old updateinfo.xml is not removed if a checksum is specified. Each publish adds a new updateinfo, which has a different checksum.

After each publish there should be only one updateinfo.xml in the repodata directory.


Related issues

Is duplicate of RPM Support - Issue #2096: Additional updateinfo.xml after second publishCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mhrivnak over 5 years ago

  • Priority changed from Normal to Low
  • Triaged changed from No to Yes

#2 Updated by bmbouter almost 5 years ago

  • Description updated (diff)

Perhaps other metadata files could leave vestiges also, the fixer should verify that an incremental publishes which must republish all files in repodata properly removes the old ones.

#4 Updated by bmbouter about 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Closing this as a duplicate. It was the first report of it, but the other one has a full reproducer.

#5 Updated by bmbouter about 4 years ago

  • Is duplicate of Issue #2096: Additional updateinfo.xml after second publish added

#6 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF