Project

Profile

Help

Issue #1637

closed

Pulp Admin returns 0 even when there are errors

Added by Ichimonji10 over 6 years ago. Updated about 3 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Master
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

It is possible to create and sync a docker repository with the following commands:

pulp-admin docker repo create \
    --feed ${feed} \
    --repo-id ${repo_id} \
    --upstream-name ${upstream_name}
pulp-admin docker repo sync --repo-id ${repo_id}

The second command returns a status code of 0 regardless of whether the sync succeeds.


Related issues

Is duplicate of Pulp - Issue #427: Return code of the operation called by pulp-admin should be propagated to pulp-adminCLOSED - WONTFIXActions
Actions #1

Updated by Ichimonji10 over 6 years ago

For an automated test which targets this issue, see https://github.com/PulpQE/pulp-smash/pull/94

Actions #2

Updated by rbarlow over 6 years ago

This is a general problem with pulp-admin - most error scenarios return 0 unfortunately.

Actions #3

Updated by Ichimonji10 over 6 years ago

Mmhmm. I remember hearing some chatter among the devs mentioning that fact.

I'll likely continue filing bugs like this. Doing so lets me provide a concrete reason for skipping certain tests.

Actions #4

Updated by ipanova@redhat.com over 6 years ago

Ichimonji10 wrote:

Mmhmm. I remember hearing some chatter among the devs mentioning that fact.

I'll likely continue filing bugs like this. Doing so lets me provide a concrete reason for skipping certain tests.

Would be helpful if you will make those issues as 'related'

Actions #5

Updated by kfiresmith over 6 years ago

wrote:

Ichimonji10 wrote:

Mmhmm. I remember hearing some chatter among the devs mentioning that fact.

I'll likely continue filing bugs like this. Doing so lets me provide a concrete reason for skipping certain tests.

Would be helpful if you will make those issues as 'related'

If anyone can point me toward the more general bug listing for this issue I'd love to weigh in - I need pulp-admin to be more predictable with exit codes so that I can count on it for use in a smaller single-Pulp-server infra that can't easily make use of Pulp event emailing.

Actions #6

Updated by Ichimonji10 over 6 years ago

Would be helpful if you will make those issues as 'related'

Sure. I'll make an effort to remember to do this. Thanks for the heads up.

Actions #7

Updated by bmbouter over 6 years ago

  • Subject changed from Pulp Admin returns 0 even when docker sync fails to Pulp Admin returns 0 even when there are errors
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes
Actions #8

Updated by bmbouter over 6 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

This was already filed so the triage team decided to track it through the original issue #427. Closing as DUPLICATE.

pulp-smash should track the resolution using #427.

Actions #9

Updated by bmbouter over 6 years ago

  • Is duplicate of Issue #427: Return code of the operation called by pulp-admin should be propagated to pulp-admin added
Actions #10

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF