Project

Profile

Help

Issue #1545

Story #1150: As a user, I can lazily fetch repositories

Progress reporting when downloading a lazy repo with a distribution is broken

Added by jcline@redhat.com almost 6 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.8.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

The files in the distribution are not being counted when reporting progress.

To reproduce:
#. create and sync (with --download-policy=on_demand) http://cdn.stage.redhat.com/content/dist/rhel/server/7/7Server/x86_64/kickstart/
#. pulp-admin repo download --repo-id <repo_id>

Associated revisions

Revision eb02c602 View on GitHub
Added by Jeremy Cline almost 6 years ago

Load _storage_path when reloading the content unit.

_storage_path is required when saving the unit. The reason this already worked with single file units is that set_storage_path is called on them and regenerates the _storage_path. This is required for multi-file units.

closes #1545

Revision eb02c602 View on GitHub
Added by Jeremy Cline almost 6 years ago

Load _storage_path when reloading the content unit.

_storage_path is required when saving the unit. The reason this already worked with single file units is that set_storage_path is called on them and regenerates the _storage_path. This is required for multi-file units.

closes #1545

History

#1 Updated by jcline@redhat.com almost 6 years ago

  • Project changed from RPM Support to Pulp
  • Status changed from NEW to ASSIGNED

After investigation this is a problem with any multi-file unit and should be fixed in platform.

#2 Updated by jcline@redhat.com almost 6 years ago

  • Status changed from ASSIGNED to POST
  • Triaged changed from No to Yes

#3 Updated by jcline@redhat.com almost 6 years ago

  • Status changed from POST to MODIFIED

#4 Updated by rbarlow over 5 years ago

  • Status changed from MODIFIED to 5
  • Platform Release set to 2.8.0

#5 Updated by dkliban@redhat.com over 5 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#6 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF