Project

Profile

Help

Issue #9427

Sync for BaseOS for AlmaLinux or CentOS 8 Stream fails with 'DistributionTree' object has no attribute 'filename'

Added by ipanova@redhat.com about 1 month ago. Updated 22 days ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 105
Quarter:


Related issues

Copied to Pulp - Backport #9440: Backport #9427 "Sync for BaseOS for AlmaLinux or CentOS 8 Stream fails with 'DistributionTree' object has no attribute 'filename'"CLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 6e18f2e7 View on GitHub
Added by ggainey about 1 month ago

Replaced incorrect use of 'filename' with 'natural_keys()' in error log.

fixes #9427. [nocoverage]

History

#1 Updated by ipanova@redhat.com about 1 month ago

  • Subject changed from Sync for BaseOS for AlmaLinux or CentOS 8 Stream 'DistributionTree' object has no attribute 'filename' to Sync for BaseOS for AlmaLinux or CentOS 8 Stream fails with 'DistributionTree' object has no attribute 'filename'

#2 Updated by ipanova@redhat.com about 1 month ago

  • Project changed from RPM Support to Pulp

#4 Updated by dalley about 1 month ago

We should have a test for this also.

#5 Updated by dalley about 1 month ago

  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes
  • Sprint set to Sprint 105

#6 Updated by ggainey about 1 month ago

  • Status changed from NEW to ASSIGNED

#7 Updated by ggainey about 1 month ago

This is def a bug, and I am prepping a PR for it. However, I cannot reproduce the problem on core/master. Using the following remotes:

    http://mirror.phx1.us.spryservers.net/almalinux/8.4/BaseOS/aarch64/kickstart/    
    https://mirror.slu.cz/rocky/8.4/BaseOS/aarch64/kickstart/ 
    http://mirror.phx1.us.spryservers.net/almalinux/8.4/BaseOS/aarch64/os/                    
    https://mirror.slu.cz/rocky/8.4/BaseOS/aarch64/os/ 
    http://mirror.centos.org/centos/8-stream/BaseOS/aarch64/os/

I have sync'd on_demand, immediate (for ks-repos), autopublish, and mirror. Duplicate-file-paths I get - but not the failure noted in the foreman-issue in #c3. core/master is 3.16dev, and there have been a number of fixes addressing remote-artifacts since 3.14. It's possible we just never hit this path any more. It's also possible that the repos were in a suboptimal state which has been fixed - CentOS8-Stream, for example, was updated yesterday.

In any event - the traceback is a bug, PR to address it incoming.

#8 Updated by ggainey about 1 month ago

  • Status changed from ASSIGNED to POST

#9 Updated by dalley about 1 month ago

  • Assignee set to ggainey

#11 Updated by dalley about 1 month ago

  • Sprint/Milestone set to 3.16.0

#12 Updated by dalley about 1 month ago

  • Copied to Backport #9440: Backport #9427 "Sync for BaseOS for AlmaLinux or CentOS 8 Stream fails with 'DistributionTree' object has no attribute 'filename'" added

#13 Updated by ggainey about 1 month ago

  • Status changed from POST to MODIFIED

#14 Updated by pulpbot 22 days ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF