Project

Profile

Help

Issue #917

qpid errors are logged during repo sync when task notifications are enabled

Added by cduryee over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Master
Platform Release:
2.7.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

On Pulp 2.7-dev, I see a lot of the following in the pulp log when I enable task notifications and perform a sync:

kombu.transport.qpid:INFO: Connected to qpid with SASL mechanism ANONYMOUS
kombu.transport.qpid:ERROR: (9116-48576) None
kombu.transport.qpid:ERROR: (9116-48576) Traceback (most recent call last):
kombu.transport.qpid:ERROR: (9116-48576)   File "/usr/lib/python2.7/site-packages/kombu/transport/qpid.py", line 1393, in
kombu.transport.qpid:ERROR: (9116-48576)     self.monitor_receivers()
kombu.transport.qpid:ERROR: (9116-48576)   File "/usr/lib/python2.7/site-packages/kombu/transport/qpid.py", line 1409, in
kombu.transport.qpid:ERROR: (9116-48576)     self._session.next_receiver()
kombu.transport.qpid:ERROR: (9116-48576)   File "<string>", line 6, in next_receiver
kombu.transport.qpid:ERROR: (9116-48576)   File "/usr/lib/python2.7/site-packages/qpid/messaging/endpoints.py", line 689,
kombu.transport.qpid:ERROR: (9116-48576)     if self._ecwait(lambda: self.incoming, timeout):
kombu.transport.qpid:ERROR: (9116-48576)   File "/usr/lib/python2.7/site-packages/qpid/messaging/endpoints.py", line 51, 
kombu.transport.qpid:ERROR: (9116-48576)     self.check_closed()
kombu.transport.qpid:ERROR: (9116-48576)   File "/usr/lib/python2.7/site-packages/qpid/messaging/endpoints.py", line 601,
kombu.transport.qpid:ERROR: (9116-48576)     raise SessionClosed()
kombu.transport.qpid:ERROR: (9116-48576) SessionClosed: None

I don't think this is affecting any functionality. Note that the notification sending in `emit.py` could be rewritten per https://github.com/celery/kombu/issues/457, which may solve this issue.

To reproduce using Fedora 21:

  • enable task notifications in server.conf and restart pulp services
  • perform some syncs
  • examine pulp log

Related issues

Related to Pulp - Issue #1006: Pulp server REST API status call causes a kombu connection exception to appear in the logs each 10s CLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 972264db View on GitHub
Added by bmbouter over 6 years ago

Fixes 917 and 1006 by stopping an thread that should have exited

https://pulp.plan.io/issues/917 https://pulp.plan.io/issues/1006

fixes #917 fixes #1006 re #711

Revision 972264db View on GitHub
Added by bmbouter over 6 years ago

Fixes 917 and 1006 by stopping an thread that should have exited

https://pulp.plan.io/issues/917 https://pulp.plan.io/issues/1006

fixes #917 fixes #1006 re #711

History

#1 Updated by cduryee over 6 years ago

  • Description updated (diff)

#2 Updated by cduryee over 6 years ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 1. Low
  • Triaged changed from No to Yes

#3 Updated by jortel@redhat.com over 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jortel@redhat.com
  • Platform Release set to 2.6.2

#4 Updated by jortel@redhat.com over 6 years ago

  • Platform Release changed from 2.6.2 to 2.7.0

#5 Updated by jortel@redhat.com over 6 years ago

Works for me (not trace) using:

  • python-kombu-3.0.24-5.pulp.fc21.noarch
  • python-qpid-0.30-2.fc21.noarch

Reproduced using:

  • kombu 3.0.25

On F21.

Seems this needs to be fixed in Kombu.

#6 Updated by jortel@redhat.com over 6 years ago

  • Status changed from ASSIGNED to NEW
  • Assignee deleted (jortel@redhat.com)
  • Platform Release deleted (2.7.0)

#7 Updated by jortel@redhat.com over 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bmbouter
  • Platform Release set to 2.7.0

#8 Updated by bmbouter over 6 years ago

  • Related to Issue #1006: Pulp server REST API status call causes a kombu connection exception to appear in the logs each 10s added

#9 Updated by bmbouter over 6 years ago

  • Status changed from ASSIGNED to POST

#10 Updated by bmbouter over 6 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#11 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from MODIFIED to 5

#12 Updated by pthomas@redhat.com over 6 years ago

  • Status changed from 5 to 6

verified

[root@qe-blade-10 ~]# rpm -qa pulp-server
pulp-server-2.7.0-0.3.beta.el6.noarch
[root@qe-blade-10 ~]# 

#13 Updated by amacdona@redhat.com almost 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#15 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF