Project

Profile

Help

Issue #9074

Accessing invalid files on the content-apps base-directory causes the cache to error

Added by gerrod 2 months ago. Updated 23 days ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 100
Quarter:

Description

To reproduce:

pulp file distribution create --name foo --base-path foo

http :24816/pulp/content/foo/ # works http :24816/pulp/content/foo # 500 error, should return 404 instead


Related issues

Is duplicate of Pulp - Issue #9073: An internal server error is raised when querying the content server without a trailing slashCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Copied to Pulp - Backport #9077: Backport 9074 "Accessing invalid files on the content-apps base-directory causes the cache to error" to 3.14.zCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision ca0ef8ff View on GitHub
Added by gerrod 2 months ago

Fix cache error when getting invalid files

fixes: #9074

History

#1 Updated by dalley 2 months ago

  • Sprint/Milestone set to 3.14.2

#2 Updated by dalley 2 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to gerrod

#3 Updated by dalley 2 months ago

  • Copied to Backport #9077: Backport 9074 "Accessing invalid files on the content-apps base-directory causes the cache to error" to 3.14.z added

#4 Updated by pulpbot 2 months ago

  • Status changed from ASSIGNED to POST

#5 Updated by daviddavis 2 months ago

  • Sprint/Milestone deleted (3.14.2)

#6 Updated by dkliban@redhat.com 2 months ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 100

#7 Updated by dalley 2 months ago

  • Is duplicate of Issue #9073: An internal server error is raised when querying the content server without a trailing slash added

#8 Updated by gerrod 2 months ago

  • Status changed from POST to MODIFIED

#9 Updated by dalley 2 months ago

  • Sprint/Milestone set to 3.15.0

#10 Updated by pulpbot 23 days ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF