Project

Profile

Help

Issue #9073

An internal server error is raised when querying the content server without a trailing slash

Added by lmjachky 2 months ago. Updated 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Steps to reproduce the behaviour:

pulp file repository create --name "test"
 
pulp file distribution create --repository "test" --name "dist-test" --base-path "dist-test-base"
 
http http://pulp3-source-fedora33.localhost.example.com/pulp/content/dist-test-base

Traceback:

  File "/usr/local/lib/pulp/lib64/python3.9/site-packages/aiohttp/web_protocol.py", line 422, in _handle_request
    resp = await self._request_handler(request)
  File "/usr/local/lib/pulp/lib64/python3.9/site-packages/aiohttp/web_app.py", line 499, in _handle
    resp = await handler(request)
  File "/home/vagrant/devel/pulpcore/pulpcore/cache/cache.py", line 161, in cached_function
    bk = await self.default_base_key(request, self)
  File "/home/vagrant/devel/pulpcore/pulpcore/content/handler.py", line 163, in find_base_path_cached
    index_p1 = await cached.exists(base_key=multiplied_base_paths)
  File "/home/vagrant/devel/pulpcore/pulpcore/cache/cache.py", line 106, in exists
    return await self.redis.exists(*base_key)
TypeError: aioredis.client.Redis.exists() argument after * must be an iterable, not function

I am running pulpcore and pulp_file from the master branch.


Related issues

Has duplicate Pulp - Issue #9074: Accessing invalid files on the content-apps base-directory causes the cache to errorCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by gerrod 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

#2 Updated by dalley 2 months ago

  • Has duplicate Issue #9074: Accessing invalid files on the content-apps base-directory causes the cache to error added

Please register to edit this issue

Also available in: Atom PDF