Project

Profile

Help

Issue #8830

closed

Memory leak in openapi.json schema generation.

Added by osapryki almost 3 years ago. Updated about 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 112
Quarter:

Description

Ticket moved to GitHub: "pulp/pulpcore/2005":https://github.com/pulp/pulpcore/issues/2005


The issue was reproduced in the Automation Hub project.

Requests to openapi.json schema cause uncontrolled growth of memory usage by gunicorn workers and eventually gunicorn worker being killed by OOMKiller.

Steps to reproduce:

Local test environment:

  • Minikube instance.
  • galaxy-api container configured with memory request\limit of 4 GiB of RAM
  • 4 gunicorn workers

After ~1200 requests to openapi.json gunicorn worker was killed due to OOM and restarted by gunicorn master process.

Also available in: Atom PDF