Project

Profile

Help

Issue #8743

Ansible playbooks fail on database migrations due to click version

Added by sli720 7 months ago. Updated 6 months ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

I run the ansible playbooks from pulp-installer 3.12.2 (also once with the latest commit of the master branch) on a fresh CentOS 8 as I did last week but suddenly it breaks on database migration with the error:

File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/click/core.py\", line 2108, in __init__", "    ) from None", "ValueError: 'default' must be a list when 'multiple' is true."], "stdout": "", "stdout_lines": []}

Is the click package incompatible? I really don't know now which version of the pulp-installer really works, cause on every rerun of the playbooks another issue appears mostly due to 3rd party incompatibilities (also django upgrade recently broke the installation) . Would it somehow possible to fix all this dependencies somewhere (which file?) cause when I check out 3.12.2 I always expect the same result? Or is there something I do wrong?


Related issues

Related to Pulp - Issue #8744: Pulp3 database migration broken with newly release click 8CLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Has duplicate Ansible Plugin - Issue #8742: Ansible playbooks fail on database migrationsCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Has duplicate Pulp - Issue #8765: pulp installation on CentOS 7 or 8CLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by sli720 7 months ago

  • Copied from Issue #8742: Ansible playbooks fail on database migrations added

#2 Updated by sli720 7 months ago

Downgraded click to 7.1.2

#3 Updated by bmbouter 7 months ago

  • Copied from deleted (Issue #8742: Ansible playbooks fail on database migrations)

#4 Updated by bmbouter 7 months ago

  • Has duplicate Issue #8742: Ansible playbooks fail on database migrations added

#5 Updated by bmbouter 7 months ago

  • Subject changed from Ansible playbooks fail on database migrations to Ansible playbooks fail on database migrations due to click version
  • Category set to Installer - Moved to GitHub issues

Downgrading click for now is the right thing to do. The issue is with RQ which declares the dependency on click so Pulp can't take an action. RQ is resolving it here https://github.com/rq/rq/pull/1465.

I propose we leave this open until RQ releases a resolved version, and then we can close this as NOTABUG once the new RQ version is available on Pypi.

Thanks for filing this issue!

#6 Updated by daviddavis 7 months ago

  • Related to Issue #8744: Pulp3 database migration broken with newly release click 8 added

#7 Updated by mdepaulo@redhat.com 7 months ago

  • Has duplicate Issue #8765: pulp installation on CentOS 7 or 8 added

#8 Updated by fao89 7 months ago

It is related to click 8.0.0, rq just released a new version that is compatible with click 8.0.0 https://github.com/rq/rq/releases/tag/v1.8.1

Problem should be solved with this new rq release, if not, please let us know which installer/pulpcore version are you using

#9 Updated by mdepaulo@redhat.com 6 months ago

  • Status changed from NEW to CLOSED - NOTABUG

Closing per fao89's comment.

Feel free to reopen if it is still present.

Please register to edit this issue

Also available in: Atom PDF