Project

Profile

Help

Issue #8742

Ansible playbooks fail on database migrations

Added by sli720 6 months ago. Updated 6 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

I run the ansible playbooks from pulp-installer 3.12.2 (also once with the latest commit of the master branch) on a fresh CentOS 8 as I did last week but suddenly it breaks on database migration with the error:

File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/click/core.py\", line 2108, in __init__", "    ) from None", "ValueError: 'default' must be a list when 'multiple' is true."], "stdout": "", "stdout_lines": []}

Is the click package incompatible? I really don't know now which version of the pulp-installer really works, cause on every rerun of the playbooks another issue appears mostly due to 3rd party incompatibilities (also django upgrade recently broke the installation) . Would it somehow possible to fix all this dependencies somewhere (which file?) cause when I check out 3.12.2 I always expect the same result? Or is there something I do wrong?


Related issues

Is duplicate of Pulp - Issue #8743: Ansible playbooks fail on database migrations due to click versionCLOSED - NOTABUG<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by sli720 6 months ago

  • Copied to Issue #8743: Ansible playbooks fail on database migrations due to click version added

#2 Updated by sli720 6 months ago

I thought this project is for the ansible playbooks. Sorry I copied to the right project. This can be closed

#3 Updated by bmbouter 6 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

#4 Updated by bmbouter 6 months ago

  • Copied to deleted (Issue #8743: Ansible playbooks fail on database migrations due to click version)

#5 Updated by bmbouter 6 months ago

  • Is duplicate of Issue #8743: Ansible playbooks fail on database migrations due to click version added

Please register to edit this issue

Also available in: Atom PDF