Project

Profile

Help

Issue #8691

Pulp fails against django 2.2.21

Added by daviddavis 3 months ago. Updated 2 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 96
Quarter:

Description

Run the test suite and you'll hit errors such as these:

File name '/var/lib/pulp/media/artifact/2a/3123f84da036df8e4233e9d9e54bbc0c0b0a7655e45e874a80bf7d67e60f03' includes path elements

The cause is this fix in django:

https://github.com/django/django/commit/04ac1624bdc2fa737188401757cf95ced122d26d


Checklist


Related issues

Related to Debian Support - Issue #8709: SuspiciousFileOperation: File name '/var/lib/pulp/tmp/..@.../tmpqe08qjln' includes path elementsCLOSED - WONTFIX<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Related to Pulp - Issue #8718: Repository sync is broken with django 2.2.22CLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Related to Pulp - Backport #8758: Backport 8691 to pulpcore 3.11CLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 446fc631 View on GitHub
Added by bmbouter 2 months ago

Fixes Pulp compatability with Django 2.2 LTS

Adjusts the upload machinery to be compatible with Django 2.2.21+. The 2.2.21 release was too strict in its checking, and 2.2.23 loosen it, so we require 2.2.23 with this PR.

closes #8691

History

#1 Updated by daviddavis 3 months ago

  • Priority changed from Normal to High
  • Sprint/Milestone set to 3.13.0
  • Triaged changed from No to Yes
  • Sprint set to Sprint 96

#2 Updated by bmbouter 3 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bmbouter

#3 Updated by daviddavis 3 months ago

  • Checklist item Set django back to `Django~=2.2.20` in requirements.txt added

#4 Updated by alikins 3 months ago

Can this get backported to 3.11 branch?

galaxy_ng is setup to use pulpcore-3.11.x at the moment, so runs into this issue.

#5 Updated by alikins 3 months ago

#6 Updated by bmbouter 3 months ago

@alikins, we could merge your PR, but it could only unblock source installs since we can't release that commit. Is that what you desired?

#7 Updated by pulpbot 3 months ago

  • Status changed from ASSIGNED to POST

#8 Updated by ggainey 3 months ago

  • Related to Issue #8709: SuspiciousFileOperation: File name '/var/lib/pulp/tmp/..@.../tmpqe08qjln' includes path elements added

#9 Updated by dalley 3 months ago

  • Related to Issue #8718: Repository sync is broken with django 2.2.22 added

#10 Updated by bmbouter 2 months ago

  • Status changed from POST to MODIFIED

#11 Updated by bmbouter 2 months ago

  • Checklist item Set django back to `Django~=2.2.20` in requirements.txt set to Done

#12 Updated by ttereshc 2 months ago

#13 Updated by pulpbot 2 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF