Project

Profile

Help

Issue #834

Exporting ISO with no new packages since specified start-date fails

Added by dvanallen almost 6 years ago. Updated almost 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.6.0
Platform Release:
2.8.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When I run an ISO export task with the --start-date flag, on a repository that hasn't had any package updates between the --start-date specified and the current time, the task fails with a somewhat mysterious message (See pastebin/attachment). I don't think it's necessarily a problem that it's throwing an error, since exporting a null ISO is undesirable. However, if there was a more targeted error message along the lines of "[Errno #] No packages updated within date range supplied", that might help point out the cause of the error.

Attached to this Issue is a copy of the following example:
http://pastebin.com/raw.php?i=pFtNAAMA

pulp_export_start-date.txt (1.08 KB) pulp_export_start-date.txt dvanallen, 04/02/2015 05:30 PM
server_calls.log (6.74 KB) server_calls.log dvanallen, 04/02/2015 05:59 PM

Associated revisions

Revision 40157a67 View on GitHub
Added by ttereshc about 5 years ago

834 - Exporting ISO with no new packages since specified start-date fails

closes #834 https://pulp.plan.io/issues/834

History

#2 Updated by mhrivnak almost 6 years ago

  • Triaged changed from No to Yes

#3 Updated by ttereshc about 5 years ago

  • Status changed from NEW to POST
  • Assignee set to ttereshc

#4 Updated by ttereshc almost 5 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#5 Updated by rbarlow almost 5 years ago

  • Platform Release set to 2.8.0

#6 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from MODIFIED to 5

#7 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#8 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF