Project

Profile

Help

Story #7561

Story #7960: FIPS and support for ALLOWED_CONTENT_CHECKSUMS

As a user, I can add checksums to ALLOWED_CONTENT_CHECKSUMS

Added by daviddavis 4 months ago. Updated about 1 month ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Sprint 87
Quarter:

Description

This would probably require the user run a script/migration that would fill in the missing checksum info.


Checklist


Related issues

Related to Pulp - Story #5216: As a user, I can configure which checksum types I want to use in PulpCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Related to Pulp - Story #7696: As a plugin developer, I have the Artifacts checked at pre-save time against the ALLOWED_CONTENT_CHECKSUMS instead of at __init__CLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 39d395d9 View on GitHub
Added by ipanova@redhat.com about 2 months ago

As a user, I have artifacts compliant with the allowed checksums.

Enabled users to add/remove checksums to ALLOWED_CONTENT_CHECKSUMS. Added check for forbidden checksums. Added command to handle artifacts with missing and fobidden checksums.

closes #7561 closes #7914

https://pulp.plan.io/issues/7914 https://pulp.plan.io/issues/7561

History

#1 Updated by daviddavis 4 months ago

This came up in a conversation with Katello.

#2 Updated by daviddavis 4 months ago

  • Related to Story #5216: As a user, I can configure which checksum types I want to use in Pulp added

#3 Updated by ipanova@redhat.com 3 months ago

  • Related to Story #7696: As a plugin developer, I have the Artifacts checked at pre-save time against the ALLOWED_CONTENT_CHECKSUMS instead of at __init__ added

#4 Updated by daviddavis 3 months ago

  • Sprint/Milestone set to 3.9.0
  • Sprint set to Sprint 85

#5 Updated by daviddavis 3 months ago

This command would have to bypass the ALLOWED_CONTENT_CHECKSUMS check[0]. The problem is that this check will run BEFORE the command. So what we'll probably want to do is check sys.argv[1] against the command name and if it matches, bypass this check.

[0] https://github.com/pulp/pulpcore/blob/7335665daa2ccfa3ae458049527ffe01dc075d78/pulpcore/app/settings.py#L285-L305

#6 Updated by ipanova@redhat.com 3 months ago

  • Checklist item add command that will recompute missing checksums added

#7 Updated by ipanova@redhat.com 3 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com

#8 Updated by pulpbot 2 months ago

  • Status changed from ASSIGNED to POST

#9 Updated by rchan 2 months ago

  • Sprint changed from Sprint 85 to Sprint 86

#10 Updated by rchan about 2 months ago

  • Sprint changed from Sprint 86 to Sprint 87

#11 Updated by ipanova@redhat.com about 2 months ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#12 Updated by pulpbot about 1 month ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#13 Updated by ipanova@redhat.com about 1 month ago

  • Parent task set to #7960

Please register to edit this issue

Also available in: Atom PDF