Project

Profile

Help

Issue #7290

`None` error with RPM Copy API

Added by iballou about 2 months ago. Updated 20 days ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 79
Quarter:

Description

When trying to copy content, my Pulp worker was dying. These logs were all I could see that was related:

Aug 05 18:07:02 centos7-katello-devel-2.cannolo.example.com pulpcore-resource-manager[4005]: pulp: rq.worker:INFO: resource-manager: Job OK (05b323d1-d351-47d1-94a7-99cf1d0396e4)
Aug 05 18:07:02 centos7-katello-devel-2.cannolo.example.com pulpcore-worker-2[4129]: python3: ../src/repodata.c:2929: repodata_add_dirstr: Assertion `dir' failed.
Aug 05 18:07:02 centos7-katello-devel-2.cannolo.example.com pulpcore-worker-2[4129]: pulp: rq.worker:WARNING: Moving job to FailedJobRegistry (work-horse terminated unexpectedly; waitpid returned 6)

Repo that I used: https://fixtures.pulpproject.org/srpm-unsigned/

Unfortunately after re-writing some of my tests I am unable to reproduce the issue.

Pulp RPM 3.4.1

Associated revisions

Revision cb39e1ff View on GitHub
Added by dalley about 1 month ago

Fix crash while copying SRPMs with depsolving enabled

[nocoverage]

closes: #7290 https://pulp.plan.io/issues/7290

Revision 50525996 View on GitHub
Added by dalley about 1 month ago

Fix crash while copying SRPMs with depsolving enabled

[nocoverage]

closes: #7290 https://pulp.plan.io/issues/7290 (cherry picked from commit cb39e1fff32a3a0879dc0a93769180b7919dafbd)

History

#1 Updated by dalley about 1 month ago

iballou, which content unit(s) were you attempting to copy? Do you know which particular options were being used?

#2 Updated by iballou about 1 month ago

dalley, all content (the 3 srpms) were being copied. It was a simple case, one source repo copying content to a dest repo. No dependency solving, no dest_base_version.

#3 Updated by dalley about 1 month ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to dalley

#4 Updated by dalley about 1 month ago

I was able to reproduce this reliably.

#5 Updated by ttereshc about 1 month ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 79

#6 Updated by pulpbot about 1 month ago

  • Status changed from ASSIGNED to POST

#7 Updated by dalley about 1 month ago

  • Status changed from POST to MODIFIED

#8 Updated by fao89 20 days ago

  • Sprint/Milestone set to 3.6.2

#9 Updated by pulpbot 20 days ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF