Project

Profile

Help

Issue #6916

closed

Latest stable docker client (2.3.0.3) fails to create 'latest' tag

Added by chouseknecht over 2 years ago. Updated about 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
3. High
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 74
Quarter:

Description

With the latest stable docker client (2.3.0.3) installed, docker push fails to make a PUT request to the API to create a latest tag. This later causes a docker pull operation to fail, because there is no latest tag.

When using podman to push the image, it uploads all the blobs first (which the docker client does as well), and then it makes 2 additional PUT calls. one to create a manifest. and another to create a tag pointing at the the manifest. The same is expected from the docker client.

The root cause seems to be the Nginx config having client_max_body_size set to 1MB. Bumping this. to unlimited resolved the problem.

Actions #1

Updated by pulpbot over 2 years ago

  • Status changed from NEW to POST
Actions #2

Updated by dkliban@redhat.com over 2 years ago

  • Assignee set to dkliban@redhat.com
  • Triaged changed from No to Yes
  • Sprint set to Sprint 74

Added by dkliban@redhat.com over 2 years ago

Revision 18d45dfe

Sets client_max_body_size to 0, unlimited for nginx

The default value for client_max_body_size is 1mb. We need it to be unlimited.

Apache's equivalent is LimitRequestBody and it defaults to unlimited.

This patch updates the 'push' test to use a large image that would require this setting to be set.

This patch also adds an additional 'pull' operation to the 'push' test to verify that the pushed image can be pulled back from the registry.

fixes: #6916 https://pulp.plan.io/issues/6916

Added by dkliban@redhat.com over 2 years ago

Revision 18d45dfe

Sets client_max_body_size to 0, unlimited for nginx

The default value for client_max_body_size is 1mb. We need it to be unlimited.

Apache's equivalent is LimitRequestBody and it defaults to unlimited.

This patch updates the 'push' test to use a large image that would require this setting to be set.

This patch also adds an additional 'pull' operation to the 'push' test to verify that the pushed image can be pulled back from the registry.

fixes: #6916 https://pulp.plan.io/issues/6916

Actions #3

Updated by dkliban@redhat.com over 2 years ago

  • Status changed from POST to MODIFIED
Actions #4

Updated by ipanova@redhat.com over 2 years ago

  • Sprint/Milestone set to 2.0.0
Actions #7

Updated by mdellweg about 2 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF