Project

Profile

Help

Issue #682

publish_repo failures that do not raise an exception are marked as successful

Added by bcourt almost 6 years ago. Updated 7 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.5
Platform Release:
2.6.2
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

When a distributor has it's publish_repo method called and the publish report return indicates a failure the task is marked as completing successfully. If the publish_repo method raises an exception the task is marked properly as failed.

+ This bug was cloned from Bugzilla Bug #1186920 +

Associated revisions

Revision cb30af0a View on GitHub
Added by bcourt almost 6 years ago

Ensure that if a publish_report is failed the task is marked as a failure.

fixes #682

Revision cb30af0a View on GitHub
Added by bcourt almost 6 years ago

Ensure that if a publish_report is failed the task is marked as a failure.

fixes #682

History

#1 Updated by dkliban@redhat.com almost 6 years ago

***** Bug 1193131 has been marked as a duplicate of this bug. ***

+ This comment was cloned from Bugzilla #1186920 comment 1 +

#2 Updated by bmbouter almost 6 years ago

  • Severity changed from High to 3. High

#3 Updated by bcourt almost 6 years ago

  • Assignee set to bcourt

#4 Updated by bcourt almost 6 years ago

  • Status changed from NEW to POST
  • Platform Release set to 2.6.2

#5 Updated by bcourt almost 6 years ago

  • Status changed from POST to MODIFIED

#6 Updated by bcourt almost 6 years ago

  • % Done changed from 0 to 100

#7 Updated by dkliban@redhat.com over 5 years ago

  • Status changed from MODIFIED to 5

#9 Updated by pthomas@redhat.com over 5 years ago

  • Status changed from 5 to 6

Verified

[root@mgmt12 puppet]# rpm -qa pulp-server
pulp-server-2.6.2-0.2.beta.el6.noarch
[root@mgmt12 puppet]# 
<\pre>
task is marked correctly as failed

<pre>

u'/var/lib/pulp/published/yum/master/yum_distributor/rad-5Client/1432052214.08/c
ups-devel-1.3.7-32.el5_11.i386.rpm'"),
(u'/var/lib/pulp/published/yum/master/yum_distributor/rad-5Client/1432052214.08/
cyrus-sasl-devel-2.1.22-5.el5.i386.rpm',
u'/var/lib/pulp/working/repos/rad-5Client/distributors/yum_distributor/cyrus-sas
l-devel-2.1.22-5.el5.i386.rpm', "[Errno 13] Permission denied:
u'/var/lib/pulp/published/yum/master/yum_distributor/rad-5Client/1432052214.08/c
yrus-sasl-devel-2.1.22-5.el5.i386.rpm'"),
(u'/var/lib/pulp/published/yum/master/yum_distributor/rad-5Client/1432052214.08/
sblim-sfcc-devel-2.2.2-51.el5.x86_64.rpm',
u'/var/lib/pulp/working/repos/rad-5Client/distributors/yum_distributor/sblim-sfc
c-devel-2.2.2-51.el5.x86_64.rpm', "[Errno 13] Permission denied:
u'/var/lib/pulp/published/yum/master/yum_distributor/rad-5Client/1432052214.08/s
blim-sfcc-devel-2.2.2-51.el5.x86_64.rpm'")]

Task Failed

/pre>

<pre>
Operations:  publish
Resources:   rad-5Client (repository)
State:       Failed
Start Time:  2015-05-25T16:04:08Z
Finish Time: 2015-05-25T16:04:09Z
Task Id:     5b7839f9-9d98-4e80-b8f2-5c5f2ff20eac

#10 Updated by dkliban@redhat.com over 5 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#12 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

#13 Updated by bmbouter 7 months ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Please register to edit this issue

Also available in: Atom PDF