Project

Profile

Help

Issue #666

Running a Node bind on a repo that is already bound to the consumer results in the repo showing up twice in the bindings

Added by pthomas@redhat.com over 6 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.5
Platform Release:
2.6.2
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
If you run node bind on a repo that is already bound to the consumer, the repo will show up twice in the bindings

Version-Release number of selected component (if applicable):
[root@rhsm-jenkins ~]# rpm -qa pulp-server
pulp-server-2.5.2-0.3.beta.el6.noarch
[root@rhsm-jenkins ~]#

How reproducible:

Steps to Reproduce:
1.Create / Sync a repo on a node server and bind the repo to a consumer
2.Setup that consumer as the node child
3.Enable and publish that repo from step1 on the node
4. Use node bind to bind that repo to the node child
5. Run consumer list
6. Run node list

Actual results:
[root@rhsm-jenkins ~]# pulp-admin consumer list
--------------------------------------------------------------------
Consumers
--------------------------------------------------------------------

Id: january
Display Name: january
Description: None
Bindings:
Confirmed: rhel6, rhel6, drpm, drpm
Unconfirmed:
Notes:

[root@rhsm-jenkins ~]# pulp-admin node list
--------------------------------------------------------------------
Child Nodes
--------------------------------------------------------------------

Id: january
Display Name: january
Description: None
Bindings:
Additive: rhel6, rhel6, drpm, drpm
Update Strategy: additive
Notes:

[root@rhsm-jenkins ~]#

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #1183069 +

Associated revisions

Revision 1c5d8d5e View on GitHub
Added by bmbouter over 6 years ago

Merge pull request #666 from bmbouter/731-docs-fixes-for-redmine

Updates extlinks and its usages to use redmine.

Revision 75e2ed3b View on GitHub
Added by jortel@redhat.com over 6 years ago

ref #666, fix dups in binding list.

Revision 75e2ed3b View on GitHub
Added by jortel@redhat.com over 6 years ago

ref #666, fix dups in binding list.

Revision 129f207a View on GitHub
Added by jortel@redhat.com over 6 years ago

Merge pull request #1843 from jortel/issue-666

ref #666, fix dups in binding list.

Revision 129f207a View on GitHub
Added by jortel@redhat.com over 6 years ago

Merge pull request #1843 from jortel/issue-666

ref #666, fix dups in binding list.

History

#1 Updated by skarmark@redhat.com over 6 years ago

  • Status changed from ASSIGNED to NEW
  • Assignee deleted (skarmark@redhat.com)

Reassigning since I still have some QA work to help preethi on my plate. Not sure whether I will be able to get this one fixed. If I get some time during the break, this could be my first PR for Pulp as a community member :).

#2 Updated by bmbouter over 6 years ago

  • Severity changed from High to 3. High

#3 Updated by jortel@redhat.com over 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jortel@redhat.com

#4 Updated by jortel@redhat.com over 6 years ago

  • Status changed from ASSIGNED to POST

#5 Updated by dkliban@redhat.com over 6 years ago

  • Platform Release set to 2.6.2

#6 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from POST to ASSIGNED

#7 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from ASSIGNED to MODIFIED

#8 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from MODIFIED to 5

#10 Updated by pthomas@redhat.com over 6 years ago

  • Status changed from 5 to 6

verified
[root@mgmt12 ~]# rpm -qa pulp-server
pulp-server-2.6.2-0.2.beta.el6.noarch
[root@mgmt12 ~]#


[root@mgmt12 ~]# pulp-admin rpm consumer bind --repo-id pulp-unit --consumer-id patch
This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Task Succeeded

[root@mgmt12 ~]# 
[root@mgmt12 ~]# 
[root@mgmt12 ~]# pulp-admin consumer list
+----------------------------------------------------------------------+
                               Consumers
+----------------------------------------------------------------------+

Id:            patch
Display Name:  patch
Description:   None
Bindings:      
  Confirmed:   pulp-unit, zoo
  Unconfirmed: 
Notes:         

[root@mgmt12 ~]# pulp-admin node repo enable --repo-id pulp-unit
Repository enabled.

Note: Repository [ pulp-unit ] will not be available for node synchronization
until published.  See: the 'node repo publish' command.

Warning: enabling with auto-publish may degrade repository synchronization
performance.

[root@mgmt12 ~]# pulp-admin node repo publish --repo-id pulp-unit
This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Publish succeeded.

[root@mgmt12 ~]# pulp-admin node bind --repo-id pulp-unit --node-id patch
Node bind succeeded.

Note: Repository [ pulp-unit ] will be included in node synchronization.

[root@mgmt12 ~]# 
[root@mgmt12 ~]# 
[root@mgmt12 ~]# pulp-admin node  sync run --node-id patch
This command may be exited via ctrl+c without affecting the request.

(1/2) Repository: pulp-unit
[==================================================] 100%

(2/2) Repository: zoo
[==================================================] 100%

Synchronization succeeded

+----------------------------------------------------------------------+
                       Child Node Synchronization
+----------------------------------------------------------------------+

Repository: 
  Action:          Added
  Content Sources: 
    Downloads:     
      Source Id:       Parent Node
      Total Failed:    0
      Total Succeeded: 4
    Total Sources: 0
  Id:              pulp-unit
  Units:           
    Added:   61
    Removed: 0
    Updated: 0

Repository: 
  Action:          Merged
  Content Sources: 
    Downloads:     
    Total Sources: 0
  Id:              zoo
  Units:           
    Added:   0
    Removed: 0
    Updated: 0

[root@mgmt12 ~]# pulp-admin consumer list
+----------------------------------------------------------------------+
                               Consumers
+----------------------------------------------------------------------+

Id:            patch
Display Name:  patch
Description:   None
Bindings:      
  Confirmed:   pulp-unit, zoo
  Unconfirmed: 
Notes:         

<\pre>

#11 Updated by dkliban@redhat.com about 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#13 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF