Project

Profile

Help

Issue #652

Two tracebacks are written to the log when syncs fail

Added by rbarlow over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4.3
Platform Release:
2.7.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
If a sync fails with an Exception, that Exception's traceback is logged (good), and then an Exception like this is logged (bad):

Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/celery/app/trace.py", line 240, in trace_task
R = retval = fun(*args, **kwargs)
File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 306, in call
return super(Task, self).__call__(*args, **kwargs)
File "/usr/lib/python2.6/site-packages/celery/app/trace.py", line 437, in protected_call
return self.run(*args, **kwargs)
File "/usr/lib/python2.6/site-packages/pulp/server/tasks/repository.py", line 210, in sync_with_auto_publish
sync_result = managers.repo_sync_manager().sync(repo_id, sync_config_override=overrides)
File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/sync.py", line 113, in sync
raise PulpExecutionException(_('Importer indicated a failed response'))
PulpExecutionException: Importer indicated a failed response

This traceback isn't useful, and sometimes users will give this to us instead of the real one since it appears "more recently" in the log.

Version-Release number of selected component (if applicable):
2.4.3-1

How reproducible:
Every time

Steps to Reproduce:
1. Edit some code to cause a traceback during a sync
2. Run the sync

Actual results:
You will see two tracebacks in the log, and the latter one is the uninformative one above.

Expected results:
You should see only one traceback in the log.

+ This bug was cloned from Bugzilla Bug #1178991 +


Related issues

Related to RPM Support - Issue #515: Bad return code upon failed repo syncCLOSED - WONTFIX<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 2622a471 View on GitHub
Added by mhrivnak over 6 years ago

Task failures of known types no longer log tracebacks.

This goes along with additional changes to plugins so they can take advantage of smarter error reporting. This includes the use of the unittest2 module for testing that error reporting.

refs #652 refs #702

Revision 2622a471 View on GitHub
Added by mhrivnak over 6 years ago

Task failures of known types no longer log tracebacks.

This goes along with additional changes to plugins so they can take advantage of smarter error reporting. This includes the use of the unittest2 module for testing that error reporting.

refs #652 refs #702

Revision 3f9c1e0a View on GitHub
Added by mhrivnak over 6 years ago

sync errors now use PulpCodedException for better error reporting

refs #652

Revision 2cbd4f57 View on GitHub
Added by mhrivnak over 6 years ago

Failure to sync no longer logs tracebacks, also reports a more helpful message.

This depends on changes in pulp that better-handle PulpCodedException reporting.

fixes #702 refs #652

Revision 2cbd4f57 View on GitHub
Added by mhrivnak over 6 years ago

Failure to sync no longer logs tracebacks, also reports a more helpful message.

This depends on changes in pulp that better-handle PulpCodedException reporting.

fixes #702 refs #652

History

#1 Updated by amacdona@redhat.com over 6 years ago

  • Related to Issue #515: Bad return code upon failed repo sync added

#2 Updated by bmbouter over 6 years ago

  • Severity changed from Medium to 2. Medium

#3 Updated by bcourt over 6 years ago

  • Assignee set to bcourt

#4 Updated by bcourt over 6 years ago

  • Assignee changed from bcourt to mhrivnak

#6 Updated by mhrivnak over 6 years ago

  • Status changed from POST to MODIFIED

#7 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from MODIFIED to 5

#8 Updated by amacdona@redhat.com almost 6 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#9 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF