Project

Profile

Help

Maintenance. Planio will be undergoing a scheduled maintenance this weekend. Between Saturday, July 24 at 9:00 UTC and Sunday, July 25, 22:00 UTC your account might observe occasional downtimes which may last up to several minutes in some cases.

Issue #515

Bad return code upon failed repo sync

Added by swaite@criticalityevent.com over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.4.0
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

Description of problem:

When running "pulp-admin rpm repo sync run" against a repo with a bad URL in it's --feed option, pulp-admin returns 0.

Version-Release number of selected component (if applicable):
pulp-server-2.4.0-1.el6.noarch

CentOS release 6.5 (Final)

How reproducible:

100%

Steps to Reproduce:
1. Create a repo with a bogus URL in it's --feed
2. Run the sync
3. Watch it bail out

Actual results:

-bash-4.1# pulp-admin rpm repo create --repo-id dummy --feed http://www.asrcdyasrco.com
-bash-4.1# pulp-admin rpm repo sync run --repo-id dummy
----------------------------------------------------------------------
Synchronizing Repository [dummy]
--------------------------------------------------------------------

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[-]
... failed

HTTPConnectionPool(host='www.asrcdyasrco.com', port=80): Max retries exceeded
with url: /repodata/repomd.xml (Caused by <class 'socket.gaierror'>: [Errno -2]
Name or service not known)

Task Failed

Importer indicated a failed response

-bash-4.1# echo $?
0

Expected results:

Return code should be non-zero to indicate failure.

+ This bug was cloned from Bugzilla Bug #1138873 +


Related issues

Related to Pulp - Issue #652: Two tracebacks are written to the log when syncs failCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by amacdona@redhat.com over 6 years ago

  • Related to Issue #652: Two tracebacks are written to the log when syncs fail added

#2 Updated by bmbouter over 6 years ago

  • Severity changed from Low to 1. Low

#3 Updated by mhrivnak over 6 years ago

  • Tags Easy Fix added

#4 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF