Project

Profile

Help

Issue #6113

closed

Fix up pulp-ansible role metadata, including license string

Added by mdepaulo@redhat.com over 4 years ago. Updated about 4 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
(Total: 0:00 h)
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 67
Quarter:

Description

At a glance, there are the following problems with the metadata files (each role's meta/main.yml):

  1. They are inconsistent with eachother in terms of some fields like the name of the author, the minimum required version of ansible (they should all specify the same version), and the supported platforms (should all be the same, and represent what we test against.)
  2. Some refer to the license as GPLv2, others as GPLv3.
  3. They want us to use this list of license strings: https://spdx.org/licenses/

ansible-pulp's LICENSE would correspond to the string: GPL-2.0-or-later

This may or may not cause issues with galaxy parsing our roles when put them in a collectoin on galaxy, but it's better to correct the metadata now.


Sub-issues 1 (0 open1 closed)

RPM Support - Task #6114: Fix up pulp_rpm_prerequisites role metadata, including license stringCLOSED - COMPLETEmdepaulo@redhat.com

Actions
Actions #1

Updated by mdepaulo@redhat.com over 4 years ago

  • Tags Pulp 3 installer added
Actions #2

Updated by mdepaulo@redhat.com over 4 years ago

  • Description updated (diff)
Actions #3

Updated by rchan over 4 years ago

Here is another ticket capturing our fixing of license in other parts of the project: https://pulp.plan.io/issues/4592 which has links to the faq and licensing discussion. If you are seeing v3 we may need to check if that is intentional or a place we may have missed.

Actions #4

Updated by mdepaulo@redhat.com over 4 years ago

  • Description updated (diff)
Actions #6

Updated by mdepaulo@redhat.com over 4 years ago

These are all the license metadatas:

./pulp-content/meta/main.yml:  license: GPL-3.0
./pulp-database/meta/main.yml:  license: GPLv2
./pulp-devel/meta/main.yml:  license: GPLv2
./pulp-redis/meta/main.yml:  license: GPL-3.0
./pulp-resource-manager/meta/main.yml:  license: GPL-3.0
./pulp-webserver/meta/main.yml:  license: GPL-3.0
./pulp-workers/meta/main.yml:  license: GPL-3.0
./pulp/meta/main.yml:  license: GPLv2

"pulp" was the very 1st role, and has always been "GPLv2".

After running "git blame" some, my theory is that at one point someone accidentally created a new role specified as GPL-3.0, and it was copied into other new roles.

And the GPLv2 was never converted to GPLv2+ ("GPL-2.0-or-later").

Actions #7

Updated by fao89 over 4 years ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 66
Actions #8

Updated by rchan about 4 years ago

  • Sprint changed from Sprint 66 to Sprint 67

Added by Mike DePaulo about 4 years ago

Revision a45411b8 | View on GitHub

Problem: role metadata is incorrect or has omissions

Solution: Update it, including the license strings: GPL-2.0 for some roles, GPL-3.0 for others -> GPL-2.0-or-later

Also remove a duplicate of copy of LICENSE (GPLv2) from the "pulp" role, which is without a COPYRIGHT file (which says GPLv2+ actually) or a COMMITMENT file.

Not addressed:

  1. The dependencies so that each service could run on different hosts. (Addressing them increases dynamic include runtime, and acheiving that entire end includes more work/testing.)

fixes: #6113 https://pulp.plan.io/issues/6113 Fix up pulp-ansible role metadata, including license string

Added by Mike DePaulo about 4 years ago

Revision a45411b8 | View on GitHub

Problem: role metadata is incorrect or has omissions

Solution: Update it, including the license strings: GPL-2.0 for some roles, GPL-3.0 for others -> GPL-2.0-or-later

Also remove a duplicate of copy of LICENSE (GPLv2) from the "pulp" role, which is without a COPYRIGHT file (which says GPLv2+ actually) or a COMMITMENT file.

Not addressed:

  1. The dependencies so that each service could run on different hosts. (Addressing them increases dynamic include runtime, and acheiving that entire end includes more work/testing.)

fixes: #6113 https://pulp.plan.io/issues/6113 Fix up pulp-ansible role metadata, including license string

Actions #9

Updated by Anonymous about 4 years ago

  • Status changed from NEW to MODIFIED
Actions #10

Updated by Anonymous about 4 years ago

Actions #11

Updated by mdepaulo@redhat.com about 4 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE
Actions #12

Updated by bmbouter about 4 years ago

  • Category set to Installer - Moved to GitHub issues
  • Tags deleted (Pulp 3 installer)

Also available in: Atom PDF