Project

Profile

Help

Issue #5857

`pulp_href` is missing from Package Groups

Added by iballou 10 months ago. Updated 12 days ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Sprint 63
Quarter:

Description

It's not in the API docs. Here's an example:

Example:

{"id"=>"system-management",
 "default"=>false,
 "user_visible"=>true,
 "name"=>"System Management",
 "description"=>"Various low-level hardware management frameworks.",
 "packages"=>
  [{"name"=>"fence-agents-all", "type"=>1, "requires"=>nil, "basearchonly"=>nil},
   {"name"=>"freeipmi", "type"=>1, "requires"=>nil, "basearchonly"=>nil},
   {"name"=>"freeipmi-bmc-watchdog", "type"=>1, "requires"=>nil, "basearchonly"=>nil},
   {"name"=>"freeipmi-ipmidetectd", "type"=>1, "requires"=>nil, "basearchonly"=>nil},
   {"name"=>"ipmitool", "type"=>1, "requires"=>nil, "basearchonly"=>nil},
   {"name"=>"openhpi", "type"=>1, "requires"=>nil, "basearchonly"=>nil},
   {"name"=>"OpenIPMI", "type"=>1, "requires"=>nil, "basearchonly"=>nil},
   {"name"=>"watchdog", "type"=>1, "requires"=>nil, "basearchonly"=>nil}],
 "biarch_only"=>false,
 "desc_by_lang"=>
  {"as"=>"নিম্ন-স্তৰৰ যান্ত্ৰিক সামগ্ৰী ব্যৱস্থাপনাৰ বিভিন্ন গাথনী।",
   "bn"=>"নিম্ন-স্তরের হার্ডওয়্যার পরিচালনার বিভিন্ন ফ্রেমওয়ার্ক।",
   "cs"=>"Různá nízkoúrovňová rozhraní pro správu hardware.",
   "de"=>"Verschiedene geringfügige Hardware-Management-Frameworks.",
   "es"=>"Varios marcos de gestión de hardware de bajo nivel.",
   "fr"=>"Divers frameworks de gestion du matériel de bas niveau.",
   "gu"=>"વિવિધ નીચા-સ્તરનાં હાર્ડવેર સંચાલન ફ્રેમવર્કો.",
   "hi"=>"विविध निम्नस्तरीय हार्डवेयर प्रबंधन फ्रेमवर्क.",
   "ia"=>"Varie infrastructuras pro gerer le hardware al nivello basse.",
   "it"=>"Framework di gestione hardware di livello-basso vari.",
   "ja"=>"多様な低レベルハードウェア管理フレームワークです。",
   "kn"=>"ಹಲವಾರು ಕೆಳ-ಮಟ್ಟದ ಯಂತ್ರಾಂಶ ನಿರ್ವಹಣಾ ಫ್ರೇಮ್<U+200C>ವರ್ಕುಗಳು.",
   "ko"=>"여러 저수준 하드웨어 관리 프레임워크.",
   "ml"=>"അനവധി ലോ-ലവല്<U+200D> ഹാര്<U+200D>ഡ്<U+200C>വെയര്<U+200D> മാനേജ്മെന്റ് ഫ്രെയിംവര്<U+200D>ക്കുകള്<U+200D>.",
   "mr"=>"विविध कमी-स्तरीय हार्डवेअर व्यवस्थापन फ्रेमवर्क्स्.",
   "or"=>"ବିଭିନ୍ନ ନିମ୍ନ-ସ୍ତରୀୟ ହାର୍ଡୱେର ପରିଚାଳନା ଫ୍ରେମୱର୍କମାନ।",
   "pa"=>"ਵੱਖ-ਵੱਖ ਘੱਟ-ਦਰਜੇ ਦੇ ਹਾਰਡਵੇਅਰ ਮੈਨੇਜਮੈਂਟ ਫਰੇਮਵਰਕ।",
   "pl"=>"Różne niskopoziomowe struktury zarządzania sprzętem.",
   "ru"=>"Различные инфраструктуры управления оборудованием на низком уровне.",
   "sv"=>"Diverse hanteringsramverk för lågnivåhårdvara.",
   "ta"=>"வேறுபட்ட குறைந்த-மட்ட வன்பொருள் மேலாண்மை கட்டமைப்புகள்.",
   "te"=>"వివిధ తక్కువ-స్థాయి హార్డువేర్ నిర్వహణా ఫ్రేమ్<U+200C>వర్క్స్.",
   "uk"=>"Різноманітні оболонки низькорівневого керування обладнанням.",
   "zh"=>"各種低層的硬體管理框架。",
   "bn_IN"=>"নিম্ন-স্তরের হার্ডওয়্যার পরিচালনার বিভিন্ন ফ্রেমওয়ার্ক।",
   "cs_CZ"=>"Různá nízkoúrovňová rozhraní pro správu hardware.",
   "de_CH"=>"Verschiedene geringfügige Hardware-Management-Frameworks.",
   "es_ES"=>"Varios marcos de gestión de hardware de bajo nivel.",
   "it_IT"=>"Framework di gestione hardware di livello-basso vari.",
   "ja_JP"=>"多様な低レベルハードウェア管理フレームワークです。",
   "pt_BR"=>"Diversas estruturas de gerenciamento de hardware de baixo nível.",
   "ru_RU"=>"Различные инфраструктуры управления оборудованием на низком уровне.",
   "ta_IN"=>"வேறுபட்ட குறைந்த-மட்ட வன்பொருள் மேலாண்மை கட்டமைப்புகள்.",
   "uk_UA"=>"Різноманітні оболонки низькорівневого керування обладнанням.",
   "zh_CN"=>"各种低级硬件管理框架。",
   "zh_TW"=>"各種低層的硬體管理框架。"},
 "name_by_lang"=>
  {"de"=>"System-Management", "es"=>"Administración de sistemas", "fr"=>"Gestion du système", "it"=>"Gestione del sistema", "ja"=>"システム管理", "ko"=>"시스템 관리", "ru"=>"Управление системой", "it_IT"=>"Gestione del sistema", "ja_JP"=>"システム管理", "pt_BR"=>"Gerenciamento de Sistema", "ru_RU"=>"Управление системой", "zh_CN"=>"系统管理", "zh_TW"=>"系統管理"},
 "digest"=>"c8d4f29ffca3d29f8ca16cbfccba720f99514f1db4331c8669c382eb66be4a78",
 "related_packages"=>
  ["/pulp/api/v3/content/rpm/packages/ecd0f5ae-2ec5-4fbd-9af7-b55af045970b/",
   "/pulp/api/v3/content/rpm/packages/80432a68-4dd7-489d-9fcd-be5b9eb67421/",
   "/pulp/api/v3/content/rpm/packages/2a7d54cf-c05e-4e24-9977-5acc54a5153a/",
   "/pulp/api/v3/content/rpm/packages/38a4664e-c7ea-4f28-bb81-9f85647f5fa8/",
   "/pulp/api/v3/content/rpm/packages/a1f24980-88cf-4966-99b8-e20d26a70e41/",
   "/pulp/api/v3/content/rpm/packages/ad806090-8c08-4200-ba08-8bab9301abff/",
   "/pulp/api/v3/content/rpm/packages/89c36326-8f1a-4496-965e-c03431e342cc/",
   "/pulp/api/v3/content/rpm/packages/41c17e0a-03d1-43df-a3ec-ec3c0f272587/",
   "/pulp/api/v3/content/rpm/packages/1471d29a-2036-4dea-aac2-b696f2a39a2d/",
   "/pulp/api/v3/content/rpm/packages/bd582b4e-e706-4a3d-ac5b-ce4dfd4696be/",
   "/pulp/api/v3/content/rpm/packages/1253f7a1-9e59-405f-8678-5e4d22fdcfd8/"]}

Associated revisions

Revision 41c1fd76 View on GitHub
Added by CodeHeeler 10 months ago

Adds fields from inherited serializer to comps types display

'pulp_href' and other fields beyond those in the comps types themselves are now displayed.

fixes #5857 https://pulp.plan.io/issues/5857

Revision f90b0a47 View on GitHub
Added by CodeHeeler 10 months ago

Adds fields from inherited serializer to comps types display

'pulp_href' and other fields beyond those in the comps types themselves are now displayed.

fixes #5857 https://pulp.plan.io/issues/5857

(cherry picked from commit 41c1fd76b2d62ffd9ee8547b72e84d8ec1ed69b3)

History

#1 Updated by ttereshc 10 months ago

Whoever works on this task, please check other serializers as well.

For this one the problem is that the parent fields are not included
https://github.com/pulp/pulp_rpm/blob/master/pulp_rpm/app/serializers.py#L722

#2 Updated by iballou 10 months ago

Looks like this is also true for Environment Groups.

#3 Updated by CodeHeeler 10 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to CodeHeeler

#4 Updated by CodeHeeler 10 months ago

  • Status changed from ASSIGNED to POST

#5 Updated by CodeHeeler 10 months ago

  • Status changed from POST to MODIFIED

#6 Updated by ttereshc 10 months ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 63

#7 Updated by CodeHeeler 10 months ago

#8 Updated by ttereshc 9 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#9 Updated by ggainey 5 months ago

  • Tags Katello added
  • Tags deleted (Katello-P2)

Please register to edit this issue

Also available in: Atom PDF