Project

Profile

Help

Issue #5564

Error when installing pulp_rpm using docs

Added by daviddavis about 1 month ago. Updated 19 days ago.

Status:
POST
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Pulp 3 RPM blocker
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

I'm getting this error when I try to run pulp_rpm:

ImportError: No module named gi

Looks like this was fixed in the pulp-rpm-prerequisites:

https://github.com/pulp/pulp-rpm-prerequisites/commit/f40f9d39bf6f4cfac2df91af313785f5209e8188

But not the pulp_rpm docs:

https://pulp-rpm.readthedocs.io/en/latest/installation.html

I think we just need to add 'python3-gobject' as a dependency but I would suggest going through and testing installation via the docs to make sure they aren't missing any other dependencies/steps.


Related issues

Related to Pulp - Issue #5488: Pulp RPM docs don't mention pulp_use_system_wide_pkgs setting MODIFIED Actions

History

#1 Updated by daviddavis about 1 month ago

  • Description updated (diff)

#2 Updated by ttereshc about 1 month ago

  • Triaged changed from No to Yes
  • Tags Pulp 3 RPM blocker added

#3 Updated by ppicka 19 days ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ppicka

#4 Updated by ppicka 19 days ago

  • Status changed from ASSIGNED to POST

#5 Updated by kersom 12 days ago

  • Related to Issue #5488: Pulp RPM docs don't mention pulp_use_system_wide_pkgs setting added

Please register to edit this issue

Also available in: Atom PDF