Project

Profile

Help

Issue #5305

When 'updateinfo' missing in repomd.xml sync task fail.

Added by ppicka over 2 years ago. Updated over 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

without <data type="updateinfo"> in repomd.xml in repository sync task will fail as we are checking updateinfo url which is not set up : https://github.com/pulp/pulp_rpm/blob/master/pulp_rpm/app/tasks/synchronizing.py#L299

We should change the way of how we checking record type when sync or use 'null' values to skip conditionals.

"description": "local variable 'updateinfo_url' referenced before assignment",
"traceback": "  File \"/usr/local/lib/pulp/lib64/python3.7/site-packages/rq/worker.py\", line 822, in perform_job\n    rv = job.perform()\n  File \"/usr/local/lib/pulp/lib64/python3.7/site-packages/rq/job.py\", line 605, in perform\n    self._result = self._execute()\n  File \"/usr/local/lib/pulp/lib64/python3.7/site-packages/rq/job.py\", line 611, in _execute\n    return self.func(*self.args, **self.kwargs)\n  File \"/home/vagrant/devel/pulp_rpm/pulp_rpm/app/tasks/synchronizing.py\", line 73, in synchronize\n    dv.create()\n  File \"/home/vagrant/devel/pulpcore-plugin/pulpcore/plugin/stages/declarative_version.py\", line 169, in create\n    loop.run_until_complete(pipeline)\n  File \"/usr/lib64/python3.7/asyncio/base_events.py\", line 568, in run_until_complete\n    return future.result()\n  File \"/home/vagrant/devel/pulpcore-plugin/pulpcore/plugin/stages/api.py\", line 209, in create_pipeline\n    await asyncio.gather(*futures)\n  File \"/home/vagrant/devel/pulpcore-plugin/pulpcore/plugin/stages/api.py\", line 43, in __call__\n    await self.run()\n  File \"/home/vagrant/devel/pulp_rpm/pulp_rpm/app/tasks/synchronizing.py\", line 308, in run\n    elif results[0].url == updateinfo_url:\n"

History

#1 Updated by ppicka over 2 years ago

  • Description updated (diff)

#2 Updated by ggainey over 2 years ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 57

#3 Updated by rchan over 2 years ago

  • Sprint changed from Sprint 57 to Sprint 58

#4 Updated by rchan about 2 years ago

  • Sprint deleted (Sprint 58)

#5 Updated by ttereshc about 2 years ago

  • Tags Pulp 3 RPM blocker added

#6 Updated by ppicka about 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ppicka

#7 Updated by ppicka about 2 years ago

  • Status changed from ASSIGNED to CLOSED - WONTFIX

Can't reproduce, sync finish when updateinfo missing in repomd, few more test done (modules present and no update info)

#8 Updated by ttereshc about 2 years ago

  • Status changed from CLOSED - WONTFIX to CLOSED - WORKSFORME

#9 Updated by bmbouter over 1 year ago

  • Tags deleted (Pulp 3 RPM blocker)

Please register to edit this issue

Also available in: Atom PDF