Project

Profile

Help

Issue #5012

ssl_client_key printed in the logs

Added by dkliban@redhat.com over 1 year ago. Updated about 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 57
Quarter:

Description

I noticed that when I performa PATCH request to update a FIle Remote, the ssl_client_key is printed in the logs at INFO level.

Associated revisions

Revision a6fd4fbd View on GitHub
Added by amacdona@redhat.com over 1 year ago

Prevent rq from logging secrets

Though the issue is specific about certain cases that shouldn't be logged, we do not have fine control over what rq logs, so the solution is to disable logging of the description (which includes the job arguments).

https://pulp.plan.io/issues/5012 fixes #5012

Revision a1838b13 View on GitHub
Added by amacdona@redhat.com over 1 year ago

Prevent rq from logging secrets

Though the issue is specific about certain cases that shouldn't be logged, we do not have fine control over what rq logs, so the solution is to disable logging of the description (which includes the job arguments).

https://pulp.plan.io/issues/5012 fixes #5012

Revision a1838b13 View on GitHub
Added by amacdona@redhat.com over 1 year ago

Prevent rq from logging secrets

Though the issue is specific about certain cases that shouldn't be logged, we do not have fine control over what rq logs, so the solution is to disable logging of the description (which includes the job arguments).

https://pulp.plan.io/issues/5012 fixes #5012

History

#1 Updated by amacdona@redhat.com over 1 year ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 55

#2 Updated by dkliban@redhat.com over 1 year ago

  • Sprint changed from Sprint 55 to Sprint 56

#3 Updated by rchan over 1 year ago

  • Sprint changed from Sprint 56 to Sprint 57

#4 Updated by amacdona@redhat.com over 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to amacdona@redhat.com

#5 Updated by amacdona@redhat.com over 1 year ago

  • Status changed from ASSIGNED to MODIFIED

#6 Updated by amacdona@redhat.com over 1 year ago

  • Status changed from MODIFIED to POST

#7 Updated by amacdona@redhat.com over 1 year ago

  • Status changed from POST to MODIFIED

#8 Updated by bmbouter about 1 year ago

  • Sprint/Milestone set to 3.0.0

#9 Updated by bmbouter about 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF