Project

Profile

Help

Issue #4884

Pulp 2 Nightly Regression: Pulp debian migrations fail on pulp DB initialization

Added by bherring 5 months ago. Updated 3 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
Severity:
2. Medium
Version - Debian:
Platform Release:
2.20.0
Blocks Release:
Target Release - Debian:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
Yes
Sprint:

Description

Problem

During the installation of Pulp 2, there is a migration failure.

Pulp 2 fails to install on CI

Failure Meta Information

Failure Type: Regression (Installation)
Failure First Seen: May 29th, 2019
Failure Point: Installation of 2-master Pulp (2.20)
Install Type: Legacy CI Ansible Playbook* Failure Point:* https://github.com/pulp/pulp-ci/blob/2e01faaa92710d6f82ace655e3a8ae7baf007e78/ci/ansible/roles/pulp/tasks/main.yaml#L232

journalctl

May 29 07:55:39 rhel76-test pulp[7817]: pulp.plugins.loader.manager:INFO: Loading auxiliary model: erratum_pkglists = pulp_rpm.plugins.db.models:ErratumPkglist
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:INFO: Applying pulp_deb.plugins.migrations version 1
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:INFO: Migration to pulp_deb.plugins.migrations version 1 complete in 0.002 seconds.
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:INFO: Applying pulp_deb.plugins.migrations version 2
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.migrations.lib.utils:INFO: *******************************************************************************
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:INFO: Migration to pulp_deb.plugins.migrations version 2 complete in 0.003 seconds.
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:INFO: Applying pulp_deb.plugins.migrations version 3
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.migrations.lib.utils:INFO: *******************************************************************************
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:INFO: Migration to pulp_deb.plugins.migrations version 3 complete in 0.003 seconds.
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:INFO: Applying pulp_deb.plugins.migrations version 4
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872) Applying migration pulp_deb.plugins.migrations.0004_add_distribution failed.
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872) Halting migrations due to a migration failure.
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: log() takes at least 3 arguments (2 given)
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872) Traceback (most recent call last):
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)   File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 280, in main
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)     return _auto_manage_db(options)
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)   File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 347, in _auto_manage_db
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)     migrate_database(options)
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)   File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 175, in migrate_database
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)     update_current_version=not options.test)
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)   File "/usr/lib/python2.7/site-packages/pulp/server/db/migrate/models.py", line 206, in apply_migration
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)     migration.migrate()
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)   File "/usr/lib/python2.7/site-packages/pulp_deb/plugins/migrations/0004_add_distribution.py", line 57, in migrate
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)     _logger.log(str(exception))
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872) TypeError: log() takes at least 3 arguments (2 given)
May 29 07:55:40 rhel76-test pulp[7817]: pulp.server.db.manage:CRITICAL: (7817-75872)

Related issues

Related to Debian Support - Issue #4138: Handling publish paths correctly CLOSED - CURRENTRELEASE Actions

Associated revisions

Revision efbfa1f0 View on GitHub
Added by quba42 5 months ago

Fix the logging in migration 0004

fixes #4884
https://pulp.plan.io/issues/4884

History

#1 Updated by bherring 5 months ago

  • Description updated (diff)

#2 Updated by quba42 5 months ago

https://github.com/pulp/pulp_deb/pull/90

I successfully reproduced the bug, and then verified that it does not occur with this fix.

#3 Updated by quba42 5 months ago

  • Status changed from NEW to MODIFIED

#4 Updated by bherring 5 months ago

Update

  • Issue was rebuilt and retested.
  • CI is now passing without issue relative to this regression.

#5 Updated by quba42 4 months ago

  • Related to Issue #4138: Handling publish paths correctly added

#6 Updated by mdellweg 4 months ago

  • Triaged changed from No to Yes

#7 Updated by mdellweg 4 months ago

  • Tags Pulp 2 added

#8 Updated by ttereshc 4 months ago

  • Platform Release set to 2.20.0

#9 Updated by ttereshc 4 months ago

  • Sprint/Milestone set to 2.20.0

#10 Updated by ttereshc 4 months ago

  • Status changed from MODIFIED to ON_QA

#11 Updated by ttereshc 3 months ago

  • Status changed from ON_QA to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF