Project

Profile

Help

Task #4691

closed

Story #4687: As a user, I can use either Python or Ruby bindings to interact with Pulp

switch pulp-swagger-codegen to openapi-generator

Added by dkliban@redhat.com almost 5 years ago. Updated about 4 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
API Bindings
Sprint:
Sprint 52
Quarter:

Description

swagger-codegen has been forked by it's original authors and now releases under the name openapi-generator[0]. It looks like this project releases much more frequently than swagger-codegen. It's a drop in replacement so we should switch to it to resolve the python 3.7 incompatibility problem in the bindings.

[0] https://openapi-generator.tech/docs/fork-qna

Also available in: Atom PDF