Project

Profile

Help

Issue #4397

Unable to sync 3 SLES Update repositories

Added by daviddavis over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.19.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 48
Quarter:

Description

Filtering by srpm:

pulp-admin rpm repo create --repo-id testrepo --feed file:///home/vagrant/testrepo/ --skip srpm
pulp-admin rpm repo sync run --force-full --repo-id testrepo

Causes the following error:

Malformed repository: metadata is missing for some packages in filelists.xml and in other.xml

While syncing without the srpm filter seems to work fine.

dupe_srpm_repodata.tgz (1.22 MB) dupe_srpm_repodata.tgz daviddavis, 02/08/2019 03:29 PM

Related issues

Copied to RPM Support - Test #4459: Unable to sync 3 SLES Update repositoriesCLOSED - COMPLETE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision eceb27c6 View on GitHub
Added by daviddavis over 1 year ago

Account for duplicate srpms in count when skipping srpms

The issue involved counting duplicate srpms when creating the package count for primary.xml which led the check against filelists.xml to fail. To create a unique package count, we're storing srpms we've seen thereby not counting them if we've seen the NEVRA already.

fixes #4397 https://pulp.plan.io/issues/4397

History

#1 Updated by daviddavis over 1 year ago

I noticed in the code that two different package counts are being returned for filtering by srpm[0] vs not filtering by srpm[1] and it looks like there's an extra check for the latter: it checks that serialized_version is not in versions. Thus, duplicate srpms are being counted when skipping srpms as opposed to when srpms are not being skipped, the code checks for dupes and thus arrives at a different package count.

[0] https://github.com/pulp/pulp_rpm/blob/aef3d5d1feb1a1ea10cd239f5bbe7a98c997922f/plugins/pulp_rpm/plugins/importers/yum/sync.py#L1072-L1074
[1] https://github.com/pulp/pulp_rpm/blob/aef3d5d1feb1a1ea10cd239f5bbe7a98c997922f/plugins/pulp_rpm/plugins/importers/yum/sync.py#L1080-L1081

#3 Updated by daviddavis over 1 year ago

  • Project changed from Pulp to RPM Support

#5 Updated by daviddavis over 1 year ago

#6 Updated by daviddavis over 1 year ago

Adding the minimal set of repodata needed to reproduce this problem.

#7 Updated by daviddavis over 1 year ago

  • Status changed from ASSIGNED to POST

#8 Updated by CodeHeeler over 1 year ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 48

#9 Updated by daviddavis over 1 year ago

  • Status changed from POST to MODIFIED

#10 Updated by bherring over 1 year ago

  • Copied to Test #4459: Unable to sync 3 SLES Update repositories added

#12 Updated by ttereshc over 1 year ago

  • Platform Release set to 2.19.0

#13 Updated by ttereshc over 1 year ago

  • Sprint/Milestone set to 2.19.0

#14 Updated by ttereshc over 1 year ago

  • Status changed from MODIFIED to 5

#15 Updated by ttereshc over 1 year ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#16 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF